summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-10-31 10:11:21 +0100
committerGuilherme Amadio <amadio@gentoo.org>2023-10-31 12:46:01 +0100
commita8a04438a4d0382bd90e66b0678e04f4240bcccb (patch)
tree5e55534e07ef0e8fba6c7b0ca55c065549541939 /sci-physics
parentsci-physics/geant: drop 4.11.0.3, 4.11.1.0 (diff)
downloadgentoo-a8a04438a4d0382bd90e66b0678e04f4240bcccb.tar.gz
gentoo-a8a04438a4d0382bd90e66b0678e04f4240bcccb.tar.bz2
gentoo-a8a04438a4d0382bd90e66b0678e04f4240bcccb.zip
sci-physics/clhep: add 2.4.7.1
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/Manifest1
-rw-r--r--sci-physics/clhep/clhep-2.4.7.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-physics/clhep/Manifest b/sci-physics/clhep/Manifest
index 0bf1be887f26..e5e459a13474 100644
--- a/sci-physics/clhep/Manifest
+++ b/sci-physics/clhep/Manifest
@@ -1,2 +1,3 @@
DIST clhep-2.4.6.2.tgz 1550248 BLAKE2B 10da3a7adc295c306d3ad57bff68489852717885eac544fe6858aed3868047cb377565f55a861751a09ea6c88584fe94b685f5dcef84c6e51afdddef8080eeb2 SHA512 cae1295d27b804c3b45c21195d8d45e9403e9449ca12d1e1a031615584f46784a1c6f75fdbc51467b901fa47057aa79077bd224994f0b6261abefc99810c2687
DIST clhep-2.4.6.4.tgz 1550911 BLAKE2B 20da75b641e9396b8b63d81f931f63ecf886ca1e02c8d4eda48ff17ba27753df66bebd758db410d7c5c2c18db0bc82641a48da1e40c48f5da0f01db9524f0d53 SHA512 7df53762a2e788bdc5e4a780bedbca7fa862b033389972cd698f364f0b399e23705554e44da3df140d6334c513b494fe90ffc2b592a36792fbb2bc7c5626da90
+DIST clhep-2.4.7.1.tgz 1229169 BLAKE2B 9bf00c634142874328bc385950c542a1836c83cb35d8366f5b6c3a4ffe5e17e108c9917a5508506f3a400f0bd9e0e635b70e8c7ac73d1db3071e876a0e073339 SHA512 2d997c23fac5c2113cd749764e9d61c9ee3b95e145e29343a4c87a81d0eeed5c0216c73e5ae1630f1462d115b4df78d061a1165949cd1babecb65a9358106095
diff --git a/sci-physics/clhep/clhep-2.4.7.1.ebuild b/sci-physics/clhep/clhep-2.4.7.1.ebuild
new file mode 100644
index 000000000000..8297ecd068ed
--- /dev/null
+++ b/sci-physics/clhep/clhep-2.4.7.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="High Energy Physics C++ library"
+HOMEPAGE="http://proj-clhep.web.cern.ch/proj-clhep/"
+SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/dist1/${P}.tgz"
+LICENSE="GPL-3 LGPL-3"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+IUSE="doc test threads"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+"
+
+S="${WORKDIR}/${PV}/CLHEP"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # respect flags
+ sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
+ # dont build test if not asked
+ if ! use test; then
+ cmake_comment_add_subdirectory test
+ fi
+ # gentoo doc directory
+ if use doc; then
+ grep -rl 'share/doc/CLHEP' |
+ xargs sed -i \
+ -e "s:share/doc/CLHEP:share/doc/${PF}:" \
+ {.,*}/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLHEP_BUILD_DOCS=$(usex doc)
+ -DCLHEP_SINGLE_THREAD=$(usex threads no yes)
+ )
+ cmake_src_configure
+}