summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-physics/heppdt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-physics/heppdt')
-rw-r--r--sci-physics/heppdt/Manifest1
-rw-r--r--sci-physics/heppdt/heppdt-3.04.01.ebuild50
-rw-r--r--sci-physics/heppdt/metadata.xml14
3 files changed, 65 insertions, 0 deletions
diff --git a/sci-physics/heppdt/Manifest b/sci-physics/heppdt/Manifest
new file mode 100644
index 000000000000..753312b53a97
--- /dev/null
+++ b/sci-physics/heppdt/Manifest
@@ -0,0 +1 @@
+DIST HepPDT-3.04.01.tar.gz 1851879 SHA256 2c1c39eb91295d3ded69e0d3f1a38b1cb55bc3f0cde37b725ffd5d722f63c0f6 SHA512 33a93b7d18c0cc64ab13923eb5edca89ed753a7f888a31c1d6a5f84f735e4042e2eaaf04e221d487976603a40fbd84cede4b4dd2bcd2e7479d97cc637dda637b WHIRLPOOL 211e9e8839e508f9929d9f69d9d1d67e633067f5957e5f59f44db6a261d3b515b7d0d9aaf49a9648ee38106ba9b9ea91abdc24820798e678eb79c640456c92ba
diff --git a/sci-physics/heppdt/heppdt-3.04.01.ebuild b/sci-physics/heppdt/heppdt-3.04.01.ebuild
new file mode 100644
index 000000000000..e2f5d2b715da
--- /dev/null
+++ b/sci-physics/heppdt/heppdt-3.04.01.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools
+
+MYP=HepPDT-${PV}
+
+DESCRIPTION="Data about each particle from the Review of Particle Properties"
+HOMEPAGE="http://lcgapp.cern.ch/project/simu/HepPDT/"
+SRC_URI="${HOMEPAGE}/download/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ # respect user flags
+ sed -i \
+ -e '/AC_SUBST(AM_CXXFLAGS)/d' \
+ configure.ac || die
+ # directories
+ sed -i \
+ -e 's:$(prefix)/data:$(datadir)/${PN}:g' \
+ data/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/src/HepPDT:${S}/src/HepPID" \
+ emake check MY_LD=-L SHEXT=so
+}
+
+src_install() {
+ default
+ use doc && mv "${ED}"usr/doc/* "${ED}"usr/share/doc/${PF}/
+ use examples && mv "${ED}"usr/examples "${ED}"usr/share/doc/${PF}/
+ rm -r "${ED}"usr/{doc,examples}
+}
diff --git a/sci-physics/heppdt/metadata.xml b/sci-physics/heppdt/metadata.xml
new file mode 100644
index 000000000000..89a8cc95903e
--- /dev/null
+++ b/sci-physics/heppdt/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ HepPDT contains the fixed data about each particle type. In other
+ words, it contains the data that can be found in the Review of
+ Particle Properties.
+ This data is conceptually split into particle information (e.g. mass)
+ and decay information. HepPDT provides a simple set of particle data
+ classes. Particle ID translation methods are in a separate HepPID
+ library, which is distributed as part of HepPDT.
+</longdescription>
+</pkgmetadata>