summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2022-06-07 15:22:35 +0200
committerGuilherme Amadio <amadio@gentoo.org>2022-06-07 16:45:25 +0200
commit2c7676d1c0552892c081470ae06e240324e4b6a3 (patch)
tree8c5e48aeeb01102da21e8141e61e54b532de4106 /sci-physics/clhep
parentsci-mathematics/pari: remove obsolete hppa workaround in an -r1. (diff)
downloadgentoo-2c7676d1c0552892c081470ae06e240324e4b6a3.tar.gz
gentoo-2c7676d1c0552892c081470ae06e240324e4b6a3.tar.bz2
gentoo-2c7676d1c0552892c081470ae06e240324e4b6a3.zip
sci-physics/clhep: version bump to 2.4.5.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/clhep')
-rw-r--r--sci-physics/clhep/Manifest1
-rw-r--r--sci-physics/clhep/clhep-2.4.5.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-physics/clhep/Manifest b/sci-physics/clhep/Manifest
index 56e400e6853a..8a69cea74cb5 100644
--- a/sci-physics/clhep/Manifest
+++ b/sci-physics/clhep/Manifest
@@ -1 +1,2 @@
DIST clhep-2.4.5.1.tgz 1551358 BLAKE2B e428946163dd525291643e9cdb4921dea64feacf4281aaa4b1466bed021e123ac29fa654e115efa3bb1d154869b4c04196f562850b5e6e162e98001a3d901727 SHA512 68612004a92c6dc036471f440bc00605b611a6f2f9f46ab7343c1f83357498bb7518c4dd2e44d0aef754188d5efbc3ac9187c2371bc6bd46ca076ab4ff13afae
+DIST clhep-2.4.5.2.tgz 1552396 BLAKE2B c4e950d988d7f88267df1da717f131b8f3e83db35b411e221415f0325e8115fcdd3dab3552301e8fb5ae7687aaf4227407643e32100fbb356fdbc076edbab928 SHA512 e63e1adbfb5476b4c1e4bb0710535afbd8962efe679f6625a5a1c4a84c109445de3bdc2c4443e3f12e858f0537a4bb700729da1a7f6e5c3c182e28bc195e9d2a
diff --git a/sci-physics/clhep/clhep-2.4.5.2.ebuild b/sci-physics/clhep/clhep-2.4.5.2.ebuild
new file mode 100644
index 000000000000..57eb9a57fa2c
--- /dev/null
+++ b/sci-physics/clhep/clhep-2.4.5.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="High Energy Physics C++ library"
+HOMEPAGE="http://proj-clhep.web.cern.ch/proj-clhep/"
+SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/dist1/${P}.tgz"
+LICENSE="GPL-3 LGPL-3"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+IUSE="doc test threads"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+"
+
+S="${WORKDIR}/${PV}/CLHEP"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # respect flags
+ sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
+ # dont build test if not asked
+ if ! use test; then
+ cmake_comment_add_subdirectory test
+ fi
+ # gentoo doc directory
+ if use doc; then
+ grep -rl 'share/doc/CLHEP' |
+ xargs sed -i \
+ -e "s:share/doc/CLHEP:share/doc/${PF}:" \
+ {.,*}/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLHEP_BUILD_DOCS=$(usex doc)
+ -DCLHEP_SINGLE_THREAD=$(usex threads no yes)
+ )
+ cmake_src_configure
+}