summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-01 10:52:35 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-05 17:55:13 +0100
commite63a348ada084c247c364afa2b69b690536e82b3 (patch)
treeae32350032a72997b77598a5a244e5e3d7f5bc55 /sci-physics/clhep/clhep-2.2.0.1.ebuild
parentsci-physics/clhep: Drop bogus CMake variables (diff)
downloadgentoo-e63a348ada084c247c364afa2b69b690536e82b3.tar.gz
gentoo-e63a348ada084c247c364afa2b69b690536e82b3.tar.bz2
gentoo-e63a348ada084c247c364afa2b69b690536e82b3.zip
sci-physics/clhep: Drop old
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-physics/clhep/clhep-2.2.0.1.ebuild')
-rw-r--r--sci-physics/clhep/clhep-2.2.0.1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sci-physics/clhep/clhep-2.2.0.1.ebuild b/sci-physics/clhep/clhep-2.2.0.1.ebuild
deleted file mode 100644
index fc50b6a42203..000000000000
--- a/sci-physics/clhep/clhep-2.2.0.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils multilib
-
-DESCRIPTION="High Energy Physics C++ library"
-HOMEPAGE="http://www.cern.ch/clhep"
-SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/tarFiles/${P}.tgz"
-LICENSE="GPL-3 LGPL-3"
-SLOT="2/${PV}"
-KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-IUSE="doc static-libs test"
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base )"
-
-S="${WORKDIR}/${PV}/CLHEP"
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # respect flags
- sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
- # no batch mode to allow parallel building (bug #437482)
- sed -i \
- -e 's:-interaction=batchmode::g' \
- cmake/Modules/ClhepBuildTex.cmake || die
- # gentoo doc directory
- sed -i \
- -e "/DESTINATION/s:doc:share/doc/${PF}:" \
- cmake/Modules/ClhepBuildTex.cmake */doc/CMakeLists.txt || die
- # dont build test if not asked
- if ! use test; then
- sed -i \
- -e '/add_subdirectory(test)/d' \
- */CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_enable test TESTING)
- $(cmake-utils_use doc CLHEP_BUILD_DOCS)
- )
- DESTDIR="${ED}" cmake-utils_src_configure
- use doc && MAKEOPTS+=" -j1"
-}
-
-src_install() {
- cmake-utils_src_install
- use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a
-}