summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-12-20 15:54:39 -0500
committerMichael Orlitzky <mjo@gentoo.org>2022-12-20 16:17:49 -0500
commitd9e5a9f5ea9c7421a450406c9e34d82cff3f61da (patch)
tree7823b899dfa59ed8a94805ca40cfd1f5bf5bdcb8 /sci-mathematics
parentsci-chemistry/gromacs: Refuse to build with double + opencl enabled (diff)
downloadgentoo-d9e5a9f5ea9c7421a450406c9e34d82cff3f61da.tar.gz
gentoo-d9e5a9f5ea9c7421a450406c9e34d82cff3f61da.tar.bz2
gentoo-d9e5a9f5ea9c7421a450406c9e34d82cff3f61da.zip
sci-mathematics/primesieve: add 11.0
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/primesieve/Manifest1
-rw-r--r--sci-mathematics/primesieve/primesieve-11.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-mathematics/primesieve/Manifest b/sci-mathematics/primesieve/Manifest
index 7b01b1f0d097..2b5abb76ed6b 100644
--- a/sci-mathematics/primesieve/Manifest
+++ b/sci-mathematics/primesieve/Manifest
@@ -1 +1,2 @@
+DIST primesieve-11.0.tar.gz 125086 BLAKE2B ac425b6435bc95efbfc3d7458b59719af390508db811e0a993a606397166771cfcb9c0269249341fb6f678aafa8bae4a89e7a914176f61a608e6ccdfd0cab22b SHA512 1be9ff9d07068cab1ca69315010238ab15e5ba3b674bd45e9a0e11d20418810ece05a8df3853796118193468ac2ac6e24391f82d6db9581658ce59ddabb5b7fc
DIST primesieve-8.0.tar.gz 119635 BLAKE2B e769cfe35752e809cf1611b3a9034bc79d16311c73d5065880cbec9c8179a2149ee9a3a6e277466691c44adf07781e1c7f9aa53f140714c4c9d408b24df17848 SHA512 213785c89868f224091fe76a74b98a896c374a7a96e2bdb44b07f4c6288bd50e22d9a563382fb512e71a1ad366d8b94e74fcc8b5f58bb94c85b4d435fbb6a571
diff --git a/sci-mathematics/primesieve/primesieve-11.0.ebuild b/sci-mathematics/primesieve/primesieve-11.0.ebuild
new file mode 100644
index 000000000000..44fb41efb869
--- /dev/null
+++ b/sci-mathematics/primesieve/primesieve-11.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="CLI and library for quickly generating prime numbers"
+HOMEPAGE="https://github.com/kimwalisch/primesieve"
+SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0/11" # subslot is first component of libprimesieve.so version
+KEYWORDS="~amd64"
+IUSE="doc +executable test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen app-text/texlive media-gfx/graphviz )"
+DEPEND=""
+RDEPEND=""
+
+DOCS=(
+ ChangeLog
+ README.md
+ doc/ALGORITHMS.md
+ doc/CPP_API.md
+ doc/C_API.md
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOC="$(usex doc)"
+ -DBUILD_PRIMESIEVE="$(usex executable)"
+ -DBUILD_STATIC_LIBS="OFF"
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ if use doc; then
+ DOCS+=(
+ "${BUILD_DIR}/doc/html"
+ "${BUILD_DIR}/doc/latex/refman.pdf"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_build doc
+}