summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2021-12-07 20:16:45 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-12-14 14:44:38 +0200
commitd35302fc8a415b6c8081e42cc35166b5fb77bcc7 (patch)
tree7d37f0c2a87263d476fec8c6c176c2c67d65be30 /sci-mathematics
parentdev-python/boto: Add py3.10 (diff)
downloadgentoo-d35302fc8a415b6c8081e42cc35166b5fb77bcc7.tar.gz
gentoo-d35302fc8a415b6c8081e42cc35166b5fb77bcc7.tar.bz2
gentoo-d35302fc8a415b6c8081e42cc35166b5fb77bcc7.zip
sci-mathematics/coq: drop redundant ebuilds
Drop old ebuilds that depend on media-libs/netpbm[zlib] They have been replaced by ebuilds that depend on media-libs/netpbm[zlib(+)] Bug: https://bugs.gentoo.org/801442 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23211 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/coq-8.11.2.ebuild90
-rw-r--r--sci-mathematics/coq/coq-8.12.0-r1.ebuild90
-rw-r--r--sci-mathematics/coq/coq-8.13.0.ebuild88
3 files changed, 0 insertions, 268 deletions
diff --git a/sci-mathematics/coq/coq-8.11.2.ebuild b/sci-mathematics/coq/coq-8.11.2.ebuild
deleted file mode 100644
index 184f6501ee75..000000000000
--- a/sci-mathematics/coq/coq-8.11.2.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop multilib
-
-MY_PV=${PV/_p/pl}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Proof assistant written in O'Caml"
-HOMEPAGE="http://coq.inria.fr/"
-SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gtk debug +ocamlopt doc"
-
-RESTRICT=test
-
-RDEPEND="
- dev-ml/camlp5:=[ocamlopt?]
- || (
- dev-ml/num
- <dev-lang/ocaml-4.09.0[ocamlopt?]
- )
- gtk? (
- dev-ml/lablgtk:3=[sourceview,ocamlopt?]
- dev-ml/lablgtk-sourceview:3=[ocamlopt?]
- )"
-DEPEND="${RDEPEND}
- dev-ml/findlib
- doc? (
- media-libs/netpbm[png,zlib]
- virtual/latex-base
- dev-tex/hevea
- dev-texlive/texlive-latexrecommended
- dev-texlive/texlive-pictures
- dev-texlive/texlive-mathscience
- dev-texlive/texlive-latexextra
- )"
-
-S=${WORKDIR}/${MY_P}
-
-src_configure() {
- ocaml_lib=$(ocamlc -where)
- local myconf=(
- -prefix /usr
- -bindir /usr/bin
- -libdir /usr/$(get_libdir)/coq
- -mandir /usr/share/man
- -coqdocdir /usr/$(get_libdir)/coq/coqdoc
- -docdir /usr/share/doc/${PF}
- -configdir /etc/xdg/${PN}
- )
-
- use debug && myconf+=( -debug )
- use doc || myconf+=( -with-doc no )
-
- if use gtk; then
- if use ocamlopt; then
- myconf+=( -coqide opt )
- else
- myconf+=( -coqide byte )
- fi
- else
- myconf+=( -coqide no )
- fi
-
- use ocamlopt || myconf+=( -byte-only )
-
- export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
- ./configure ${myconf[@]} || die "configure failed"
-}
-
-src_compile() {
- emake STRIP="true" -j1 world VERBOSE=1
-}
-
-src_test() {
- emake STRIP="true" check VERBOSE=1
-}
-
-src_install() {
- emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
- dodoc README.md CREDITS
-
- use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
-}
diff --git a/sci-mathematics/coq/coq-8.12.0-r1.ebuild b/sci-mathematics/coq/coq-8.12.0-r1.ebuild
deleted file mode 100644
index 3efa55afdcd4..000000000000
--- a/sci-mathematics/coq/coq-8.12.0-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop multilib
-
-MY_PV=${PV/_p/pl}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Proof assistant written in O'Caml"
-HOMEPAGE="http://coq.inria.fr/"
-SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gtk debug +ocamlopt doc"
-
-RESTRICT=test
-
-RDEPEND="
- dev-ml/camlp5:=[ocamlopt?]
- || (
- dev-ml/num
- <dev-lang/ocaml-4.09.0[ocamlopt?]
- )
- gtk? (
- dev-ml/lablgtk:3=[sourceview,ocamlopt?]
- dev-ml/lablgtk-sourceview:3=[ocamlopt?]
- )"
-DEPEND="${RDEPEND}
- dev-ml/findlib
- doc? (
- media-libs/netpbm[png,zlib]
- virtual/latex-base
- dev-tex/hevea
- dev-texlive/texlive-latexrecommended
- dev-texlive/texlive-pictures
- dev-texlive/texlive-mathscience
- dev-texlive/texlive-latexextra
- )"
-
-S=${WORKDIR}/${MY_P}
-
-src_configure() {
- ocaml_lib=$(ocamlc -where)
- local myconf=(
- -prefix /usr
- -bindir /usr/bin
- -libdir /usr/$(get_libdir)/coq
- -mandir /usr/share/man
- -coqdocdir /usr/$(get_libdir)/coq/coqdoc
- -docdir /usr/share/doc/${PF}
- -configdir /etc/xdg/${PN}
- )
-
- use debug && myconf+=( -debug )
- use doc || myconf+=( -with-doc no )
-
- if use gtk; then
- if use ocamlopt; then
- myconf+=( -coqide opt )
- else
- myconf+=( -coqide byte )
- fi
- else
- myconf+=( -coqide no )
- fi
-
- use ocamlopt || myconf+=( -byte-only )
-
- export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
- ./configure ${myconf[@]} || die "configure failed"
-}
-
-src_compile() {
- emake STRIP="true" -j1 world VERBOSE=1
-}
-
-src_test() {
- emake STRIP="true" check VERBOSE=1
-}
-
-src_install() {
- emake STRIP="true" COQINSTALLPREFIX="${D}" install -j1 VERBOSE=1
- dodoc README.md CREDITS
-
- use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
-}
diff --git a/sci-mathematics/coq/coq-8.13.0.ebuild b/sci-mathematics/coq/coq-8.13.0.ebuild
deleted file mode 100644
index 88e7292b5a63..000000000000
--- a/sci-mathematics/coq/coq-8.13.0.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop findlib
-
-MY_PV=${PV/_p/pl}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Proof assistant written in O'Caml"
-HOMEPAGE="http://coq.inria.fr/"
-SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gtk debug +ocamlopt doc"
-
-RESTRICT="test"
-
-RDEPEND="
- dev-ml/zarith
- || (
- dev-ml/num
- <dev-lang/ocaml-4.09.0[ocamlopt?]
- )
- gtk? (
- dev-ml/lablgtk:3=[sourceview,ocamlopt?]
- dev-ml/lablgtk-sourceview:3=[ocamlopt?]
- )"
-DEPEND="${RDEPEND}
- doc? (
- media-libs/netpbm[png,zlib]
- virtual/latex-base
- dev-tex/hevea
- dev-texlive/texlive-latexrecommended
- dev-texlive/texlive-pictures
- dev-texlive/texlive-mathscience
- dev-texlive/texlive-latexextra
- )"
-
-src_configure() {
- ocaml_lib=$(ocamlc -where)
- local myconf=(
- -prefix /usr
- -bindir /usr/bin
- -libdir /usr/$(get_libdir)/coq
- -mandir /usr/share/man
- -coqdocdir /usr/$(get_libdir)/coq/coqdoc
- -docdir /usr/share/doc/${PF}
- -configdir /etc/xdg/${PN}
- )
-
- use debug && myconf+=( -debug )
- use doc || myconf+=( -with-doc no )
-
- if use gtk; then
- if use ocamlopt; then
- myconf+=( -coqide opt )
- else
- myconf+=( -coqide byte )
- fi
- else
- myconf+=( -coqide no )
- fi
-
- use ocamlopt || myconf+=( -byte-only )
-
- export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
- ./configure ${myconf[@]} || die "configure failed"
-}
-
-src_compile() {
- emake STRIP="true" -j1 world VERBOSE=1
-}
-
-src_test() {
- emake STRIP="true" check VERBOSE=1
-}
-
-src_install() {
- emake STRIP="true" COQINSTALLPREFIX="${D}" install -j1 VERBOSE=1
- dodoc README.md CREDITS
-
- use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
-}