summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-16 10:12:26 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-16 10:12:26 +0200
commit91df1804da2356a3cd4aa018837623c90fad9aa1 (patch)
treef16b47c78b11f586a03c1d72b1d8eda08ffdcf34 /sci-mathematics
parentsci-mathematics/gmp-ecm: [QA] use tc-check-openmp correctly (diff)
downloadgentoo-91df1804da2356a3cd4aa018837623c90fad9aa1.tar.gz
gentoo-91df1804da2356a3cd4aa018837623c90fad9aa1.tar.bz2
gentoo-91df1804da2356a3cd4aa018837623c90fad9aa1.zip
sci-mathematics/gretl: [QA] use tc-check-openmp correctly
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gretl/gretl-2021d.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sci-mathematics/gretl/gretl-2021d.ebuild b/sci-mathematics/gretl/gretl-2021d.ebuild
index dcc6aca2cfbe..957d8f5cb180 100644
--- a/sci-mathematics/gretl/gretl-2021d.ebuild
+++ b/sci-mathematics/gretl/gretl-2021d.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -54,9 +54,11 @@ PATCHES=(
DOCS=( README ChangeLog CompatLog )
pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- use openmp && tc-check-openmp
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {