summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-11-03 11:04:09 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-11-03 17:03:25 -0400
commit5d25fb125b5d9a4b03f8fa6840c56ef87615134d (patch)
treecdd37ea501e921ace52ea54b9ae9ca1e258edb16 /sci-mathematics
parentdev-perl/IO-All: EAPI=8 bump (diff)
downloadgentoo-5d25fb125b5d9a4b03f8fa6840c56ef87615134d.tar.gz
gentoo-5d25fb125b5d9a4b03f8fa6840c56ef87615134d.tar.bz2
gentoo-5d25fb125b5d9a4b03f8fa6840c56ef87615134d.zip
sci-mathematics/flint: new upstream version 2.8.3.
This contains an important mathematical bugfix, but USE=doc still isn't usable (for a new reason though). Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/flint/Manifest2
-rw-r--r--sci-mathematics/flint/flint-2.8.3.ebuild (renamed from sci-mathematics/flint/flint-2.8.1.ebuild)12
2 files changed, 10 insertions, 4 deletions
diff --git a/sci-mathematics/flint/Manifest b/sci-mathematics/flint/Manifest
index 5712997a6c54..5035c1a47d37 100644
--- a/sci-mathematics/flint/Manifest
+++ b/sci-mathematics/flint/Manifest
@@ -1,2 +1,2 @@
DIST flint-2.7.1.tar.gz 4945081 BLAKE2B 9dcc4b0062be08778cd8ada1794a73237ea091a7bff4a4673aa59eac9b414ed90e0291b9547bdf72aa30e48da11f98ff983267ea2e3dd1d75fcec00b24c86ca9 SHA512 abea97228e91089d82a9a44714e719064bef261c45f5f5b24700955bb841cc98a8182e04e6054fcbcaa3bd92f2f95a82bd5d168ec2171af6a58d4f71eb0a479a
-DIST flint-2.8.1.tar.gz 5211285 BLAKE2B a200654190868931e4db94d3100605527cfbcbe3f95bae450187750641017869ae788d79fc568aa25b16f1c1c02a73e15e6739278b035780ad56754215858058 SHA512 8629e4d4bc374128e26447a60b63906e78b2d1c9f66658ce763a7eb89f851cf1aea8b2f328a9aeb0f785cfdab9a492d7de55032990ef395da7a1034ee25fb520
+DIST flint-2.8.3.tar.gz 5212158 BLAKE2B 4e9e98565399313cc78e86e00af42c780937f0c3be1f7305122e7f23d0a9d93766726818d371657a31eaf80fe692253cde889c9e13c2b47cc5b4c023baba5bdc SHA512 0ce5f92619655826ef0064403dcaa539dde336e404c9a7e85cb4baaed40438886eecdfb36d6b56ee87a1373a010da798e122ee216e88b861e51de7612d5ba501
diff --git a/sci-mathematics/flint/flint-2.8.1.ebuild b/sci-mathematics/flint/flint-2.8.3.ebuild
index c0196d38a199..155984f2418a 100644
--- a/sci-mathematics/flint/flint-2.8.1.ebuild
+++ b/sci-mathematics/flint/flint-2.8.3.ebuild
@@ -1,16 +1,20 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# ninja doesn't like "-lcblas" so using make.
CMAKE_MAKEFILE_GENERATOR="emake"
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit cmake python-any-r1
DESCRIPTION="Fast Library for Number Theory"
HOMEPAGE="http://www.flintlib.org/"
-SRC_URI="http://www.flintlib.org/${P}.tar.gz"
+
+# flintlib.org tarballs have been broken in the past, Bill Hart suggests
+# we get them from Github (which he has control over).
+SRC_URI="https://github.com/wbhart/flint2/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
LICENSE="LGPL-2.1+"
@@ -36,6 +40,8 @@ DEPEND="dev-libs/gmp:=
virtual/cblas"
RDEPEND="${DEPEND}"
+S="${WORKDIR}/flint2-${PV}"
+
src_configure() {
local mycmakeargs=(
-DWITH_NTL="$(usex ntl)"