summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2023-12-07 14:27:50 +1300
committerMichael Orlitzky <mjo@gentoo.org>2023-12-06 20:41:46 -0500
commit480020dcc968b77cf387df1c7ef9c58309a3903a (patch)
tree2590ae39dd83c09ab044eeb9f108a71d20527908 /sci-mathematics
parentnet-misc/gallery-dl: live ebuild tweaks (diff)
downloadgentoo-480020dcc968b77cf387df1c7ef9c58309a3903a.tar.gz
gentoo-480020dcc968b77cf387df1c7ef9c58309a3903a.tar.bz2
gentoo-480020dcc968b77cf387df1c7ef9c58309a3903a.zip
sci-mathematics/singular: add 4.3.2_p10
Closes: https://bugs.gentoo.org/919355 Closes: https://github.com/gentoo/gentoo/pull/34158 Signed-off-by: François Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/singular/Manifest1
-rw-r--r--sci-mathematics/singular/singular-4.3.2_p10.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/sci-mathematics/singular/Manifest b/sci-mathematics/singular/Manifest
index 5c2c0d474c6a..f08c117bbdb9 100644
--- a/sci-mathematics/singular/Manifest
+++ b/sci-mathematics/singular/Manifest
@@ -1 +1,2 @@
DIST singular-4.3.2p1.tar.gz 15013729 BLAKE2B 00276f2417cd9e2b71afcae66c2aeb7f9d4f434f5a90deeee56dded66e6d5e0020ab0b06b6561e41f5b196262993732ffeb9196f59315f1b6a081b0029fc99a1 SHA512 451054a0bf33b9d1c94a63f0946e1eb7b3e7b92bc025b6aa4f64e65183aeebd6354bac5f87f6e8b35cb713b30e97af5c66f92f02683144bb426f5e3a828db616
+DIST singular-4.3.2p10.tar.gz 20848377 BLAKE2B 2487eb40c70dca516eca94585c59be0ebfeb43edce87dd16a2874bbefbe502fadcfda1164922ab7738a257e59f9e6b6535b7447702d325b36f1358ed5048c7dd SHA512 9b914e8db2c4936184594200b07d37fc952a1399c3accb1ed30ec4a4b450afd3e3c174343e1169520d0d1ed6ac2e6d261fbbb731082e07b7caced4b5790f295e
diff --git a/sci-mathematics/singular/singular-4.3.2_p10.ebuild b/sci-mathematics/singular/singular-4.3.2_p10.ebuild
new file mode 100644
index 000000000000..c67d67fdb8b1
--- /dev/null
+++ b/sci-mathematics/singular/singular-4.3.2_p10.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+MY_PN=Singular
+MY_PV=$(ver_rs 3 '')
+# Consistency is different...
+MY_DIR2=$(ver_cut 1-3 ${PV})
+MY_DIR=$(ver_rs 1- '-' ${MY_DIR2})
+
+DESCRIPTION="Computer algebra system for polynomial computations"
+HOMEPAGE="https://www.singular.uni-kl.de/ https://github.com/Singular/Singular"
+SRC_URI="https://www.singular.uni-kl.de/ftp/pub/Math/${MY_PN}/SOURCES/${MY_DIR}/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_DIR2}"
+
+# Most files say "version 2 or version 3 of the License," which is not
+# quite GPL-2+, and is why we have listed GPL-2 below. But AFAIK there
+# are no GPL-2-only files.
+LICENSE="BSD GPL-2 GPL-2+ GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86 ~x86-linux"
+IUSE="emacs examples polymake +readline static-libs"
+
+# The interactive help uses "info" from sys-apps/texinfo.
+RDEPEND="
+ dev-lang/perl
+ dev-libs/gmp:0
+ dev-libs/ntl:=
+ sci-libs/cddlib
+ sci-mathematics/flint
+ sys-apps/texinfo
+ emacs? ( >=app-editors/emacs-23.1:* )
+ polymake? ( sci-mathematics/polymake )
+ readline? ( sys-libs/readline )
+"
+DEPEND="${RDEPEND}"
+
+SITEFILE=60${PN}-gentoo.el
+
+src_configure() {
+ local myconf=(
+ --disable-debug
+ --disable-doc
+ --disable-optimizationflags
+ --disable-pyobject-module
+ --disable-python
+ --disable-python-module
+ --disable-python_module
+ --enable-factory
+ --enable-gfanlib
+ --enable-libfac
+ --with-flint
+ --with-gmp
+ --with-libparse
+ --with-ntl
+ --without-python
+ --without-pythonmodule
+ $(use_enable emacs)
+ $(use_enable polymake polymake-module)
+ $(use_enable static-libs static)
+ $(use_with readline)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ pushd "${S}"/emacs
+ elisp-compile *.el || die "elisp-compile failed"
+ popd
+ fi
+}
+
+src_install() {
+ # Do not compress singular's info file (singular.hlp)
+ # some consumer of that file do not know how to deal with compression
+ docompress -x /usr/share/info
+
+ default
+
+ dosym Singular /usr/bin/"${PN}"
+
+ # purge .la file
+ find "${ED}" -name '*.la' -delete || die
+}
+
+src_test() {
+ # SINGULAR_PROCS_DIR need to be set to "" otherwise plugins from
+ # an already installed version of singular may be used and cause segfault
+ # See https://github.com/Singular/Sources/issues/980
+ SINGULAR_PROCS_DIR="" emake check
+}
+
+pkg_postinst() {
+ einfo "Additional functionality can be enabled by installing"
+ einfo "sci-mathematics/4ti2"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}