summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-07-27 18:40:28 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-07-27 19:12:17 -0400
commit30f0165c7d521196df0daeecb165d25ee46b130c (patch)
tree2870584fa22d41b4145f0e127e5887b0fab9d6c2 /sci-mathematics
parentsci-mathematics/primesieve: add 12.3 (diff)
downloadgentoo-30f0165c7d521196df0daeecb165d25ee46b130c.tar.gz
gentoo-30f0165c7d521196df0daeecb165d25ee46b130c.tar.bz2
gentoo-30f0165c7d521196df0daeecb165d25ee46b130c.zip
sci-mathematics/primecount: add 7.13
Closes: https://bugs.gentoo.org/936503 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/primecount/Manifest1
-rw-r--r--sci-mathematics/primecount/primecount-7.13.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-mathematics/primecount/Manifest b/sci-mathematics/primecount/Manifest
index 1e26ee5dd234..cfec9e09faf2 100644
--- a/sci-mathematics/primecount/Manifest
+++ b/sci-mathematics/primecount/Manifest
@@ -1 +1,2 @@
+DIST primecount-7.13.tar.gz 431676 BLAKE2B a02ba71af2b545f2a89e83018c3e9f2ab6ad5e567e5e72e3a0e85ccc132f1bc54b7dcc8b51ccdb1e727f6edcf050a856cee15e4180cc46a54fa8c5fe834d8cd8 SHA512 836c181e586a691708049d3ba04672e1dd4922160e17b3b03737ea55512186d3a529e003af08ff2e78f7bf7349cce0819c98144cfb89bd8208e4bad8124ae17b
DIST primecount-7.6.tar.gz 382074 BLAKE2B f665db8724b32b2f057db96fdd6421d7a996ed4bda7f43cd405e6c05b59abab8672407c41b6fafdd9c68dae3f51b65305112c0724c95ce3fdb33b9dbfaadfbff SHA512 643372d9a011dba8a49f21eabc00068b77a5ef5dc6d12e6b55230b97f14dc9d1d855bb7ad662beda548e4ff1396f1b06d473e2fe4b81e7dbe9926aaadc4da360
diff --git a/sci-mathematics/primecount/primecount-7.13.ebuild b/sci-mathematics/primecount/primecount-7.13.ebuild
new file mode 100644
index 000000000000..c6490b03ae75
--- /dev/null
+++ b/sci-mathematics/primecount/primecount-7.13.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Highly optimized CLI and library to count primes"
+HOMEPAGE="https://github.com/kimwalisch/primecount"
+SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/7" # subslot is first component of libprimecount.so version
+KEYWORDS="~amd64"
+IUSE="+executable openmp test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=sci-mathematics/primesieve-12.0:="
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ ChangeLog
+ README.md
+ doc/Credits.md
+ doc/Easy-Special-Leaves.md
+ doc/Hard-Special-Leaves.md
+ doc/Records.md
+ doc/References.md
+ doc/alpha-factor-dr.pdf
+ doc/alpha-factor-gourdon.pdf
+ doc/alpha-factor-lmo.pdf
+ doc/libprimecount.md
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_LIBPRIMESIEVE="OFF"
+ -DBUILD_PRIMECOUNT="$(usex executable)"
+ -DBUILD_STATIC_LIBS="OFF"
+ -DBUILD_TESTS="$(usex test)"
+ -DWITH_OPENMP="$(usex openmp)"
+ )
+
+ cmake_src_configure
+}