summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-23 15:16:51 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-23 15:16:51 +0100
commit24d75f9c5369eceacf7fd61ea241f21934545d6b (patch)
treeea5b16eaaab0d23116edc87a96d9166545e81fc2 /sci-mathematics
parentnet-mail/mailutils: Fix building with GCC 10 (diff)
downloadgentoo-24d75f9c5369eceacf7fd61ea241f21934545d6b.tar.gz
gentoo-24d75f9c5369eceacf7fd61ea241f21934545d6b.tar.bz2
gentoo-24d75f9c5369eceacf7fd61ea241f21934545d6b.zip
*/*: [QA] Remove redundant --docdir/--htmldir
Closes: https://github.com/gentoo/gentoo/pull/14742 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/rw/rw-0.8-r1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sci-mathematics/rw/rw-0.8-r1.ebuild b/sci-mathematics/rw/rw-0.8-r1.ebuild
index b4fe3468daa3..4ccfc56281e1 100644
--- a/sci-mathematics/rw/rw-0.8-r1.ebuild
+++ b/sci-mathematics/rw/rw-0.8-r1.ebuild
@@ -20,25 +20,23 @@ DEPEND="executable? ( >=dev-libs/igraph-0.6 )"
RDEPEND="${DEPEND}
!media-gfx/xpaint"
-DOCDIR="/usr/share/doc/${PF}"
-
src_prepare() {
# The upstream tarball for v0.8 contains SYMLINKS to ar-lib,
# compile, install-sh, ltmain.sh, etc. And those symlinks don't
# always point to a working location for us, so we have to
# (re)generate actual files for that stuff. Bug 696986.
- eautoreconf
default
+ eautoreconf
}
src_configure() {
- econf $(use_enable executable) --docdir="${EPREFIX}${DOCDIR}"
+ econf $(use_enable executable)
}
src_install() {
+ default
# The examples graphs are meant to be fed uncompressed into the 'rw'
# program. The rest of the docs are small so just leave everything
# uncompressed.
- docompress -x "${DOCDIR}"
- default
+ docompress -x /usr/share/doc/${PF}
}