summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-11 02:18:21 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-11 02:19:38 +0200
commit1248ca497808075120f97fa0218151e8b113bd51 (patch)
treed719b2d4b3f333c4bc522a70a811b3810b5d28b3 /sci-mathematics
parentdev-lang/crystal: bump to 1.10.0 (diff)
downloadgentoo-1248ca497808075120f97fa0218151e8b113bd51.tar.gz
gentoo-1248ca497808075120f97fa0218151e8b113bd51.tar.bz2
gentoo-1248ca497808075120f97fa0218151e8b113bd51.zip
sci-mathematics/kissat: bump to 3.1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/kissat/Manifest1
-rw-r--r--sci-mathematics/kissat/kissat-3.1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-mathematics/kissat/Manifest b/sci-mathematics/kissat/Manifest
index be9a0662fb22..906a03b62d91 100644
--- a/sci-mathematics/kissat/Manifest
+++ b/sci-mathematics/kissat/Manifest
@@ -1,2 +1,3 @@
DIST kissat-3.0.0.tar.gz 466704 BLAKE2B 453f894884e80cfd0ee7022adbde0439d64e31a402c4bfa92f022ad41699cc5c11682d5b9069cf33f8a779afa255f103987519bc9412b49f54480bd688fbc4eb SHA512 2a5b7b9c9bb74ca8395399425519c138e135eb9adfb6e802ce8d7544c9d53e0b7687f86e6a032fcdff1c6fc01770dd7e7449e488e0ddf3e4ee1199e1448a0862
DIST kissat-3.1.0.tar.gz 470710 BLAKE2B bd79a480209d6ff35aa431dc294018cd78ef06e5f6c431fcd23206a72183c3f18eb4a4b9b57f471f2edc7c9224a52d00ae1d75f6c9af050b1fa7e667776932a7 SHA512 226090d4e8c42197709e08341dd4623cbf7e63f2fee72e59305ab7643c3e59cfc1f9f3abb5a766e3572137b45018ed788bbdfb486e6b8d86a7317f959358f2e8
+DIST kissat-3.1.1.tar.gz 471004 BLAKE2B ce98105f2701e9dfab8dc555ace2d6891015e25bd23f09c1b2706ddb757f7580a555bdc20340d6880f2c4a0c786a71fd16466ab06a9c7499c81e4832665ce6c3 SHA512 f1f1e20a48a682ba5e0cbc938136421a95131e4bde058002ee2ab763f565105765a63d4c0d031f84b76a0bed4d5902a8120666c9a98fc541acb68009f6e503ed
diff --git a/sci-mathematics/kissat/kissat-3.1.1.ebuild b/sci-mathematics/kissat/kissat-3.1.1.ebuild
new file mode 100644
index 000000000000..4c1fed10488f
--- /dev/null
+++ b/sci-mathematics/kissat/kissat-3.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Keep-it-simple and clean bare metal SAT solver written in C"
+HOMEPAGE="http://fmv.jku.at/kissat/
+ https://github.com/arminbiere/kissat/"
+SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-rel-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="!>=x11-terms/kitty-0.27"
+
+src_configure() {
+ local myopts=(
+ CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+ --kitten
+ --statistics
+ )
+ sh ./configure "${myopts[@]}" || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ dolib.a build/libkissat.a
+ exeinto /usr/bin/
+ doexe build/{kissat,kitten}
+ dodoc CONTRIBUTING NEWS.md README.md
+}