summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-05 17:58:39 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-06 00:09:11 +0200
commit0b9906488af2fcba4901e56b417d0c6bb923a089 (patch)
treedbd4f8f26274d8e092454b137e7f5ffa713c4f08 /sci-mathematics
parentdev-ml/lablgtk-sourceview: bump to 3.1.2 (diff)
downloadgentoo-0b9906488af2fcba4901e56b417d0c6bb923a089.tar.gz
gentoo-0b9906488af2fcba4901e56b417d0c6bb923a089.tar.bz2
gentoo-0b9906488af2fcba4901e56b417d0c6bb923a089.zip
sci-mathematics/coq: bump to 8.16.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/Manifest1
-rw-r--r--sci-mathematics/coq/coq-8.16.0.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index 16f3349c8623..add6ec522449 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -4,3 +4,4 @@ DIST coq-8.13.0.tar.gz 7010242 BLAKE2B bf9ec96b6698a2371be3164f65424a8ffb273252a
DIST coq-8.15.0.tar.gz 7215106 BLAKE2B 512fde593f6e7fb8b410b5debf5a78bc5d0d181ed7207c00669fc33fa39c2d7e57860f3afbcfc9defd2093115242ad176a5451d9bb309483ba2172e2b0521d02 SHA512 be6c799b6635875255f7288b9bae5f9108660308f299823155d41353e96fbed4e41e1fc8896fe9653c095da740a80dbf5a1add6b28d279eb7b65365eeaff54ab
DIST coq-8.15.1.tar.gz 7221470 BLAKE2B 6783ceb1ae6bcc7107b7bd1b61ab4566da9e24b8c87966cf1b64004fa19b92a5324d317f3002f30dd4c724bc5b27109c507dfb8e3ee64a9ace28bdb83b0a25e2 SHA512 8ae7bde19b4c098c0fad4206a349c50c7fc2537cbeae68e03d38020fd73f15df46e248b1e7cbbf297c1ccf44f9dd62b1179148588fcb5d397e30141cca954a3c
DIST coq-8.15.2.tar.gz 7222794 BLAKE2B 2f187982a56cb0a512af838ee321b245f9a44b0c32f5413aafcef8e5b7f933e9b05ba521c3e681a6c6973ca2b7ec5965a8b69b2febb978ce7cf246755187f656 SHA512 6a5487912dedb6e54145bf3f177a091cffe13429ba2f73db7c1cc241fe10e86340c968e19cefba7d680facce55f4e914cbd16a317264b109a6f9a01ec822a8c5
+DIST coq-8.16.0.tar.gz 7397421 BLAKE2B 25b94002c4d1d1266ef948f0276df74d6a60c5b5100c7126232e0e33642be3ec14f33acfff5d0d5c17681676338374f694ca7c8c35200e522e480c3791f69dd8 SHA512 f324b68efcec0680a52c92d6e2fdd340a0e360e7d56d7fc3b4b781af3bec923d2fa2fdbb139b07d2253568a657a09c0d3da4cd5bdf984a6ab913e606056df4b3
diff --git a/sci-mathematics/coq/coq-8.16.0.ebuild b/sci-mathematics/coq/coq-8.16.0.ebuild
new file mode 100644
index 000000000000..8f3da8dda4ab
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.16.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+inherit desktop dune
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gtk debug +ocamlopt"
+RESTRICT="test" # fails
+
+RDEPEND="
+ dev-ml/zarith:=
+ || (
+ dev-ml/num
+ <dev-lang/ocaml-4.09.0[ocamlopt?]
+ )
+ gtk? (
+ >=dev-ml/lablgtk-3.1.2:3=[sourceview,ocamlopt?]
+ >=dev-ml/lablgtk-sourceview-3.1.2:3=[ocamlopt?]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ >=dev-java/antlr-4.7:4
+ dev-python/antlr4-python3-runtime
+ dev-python/beautifulsoup4
+ dev-python/pexpect
+ dev-python/sphinx_rtd_theme
+ dev-python/sphinxcontrib-bibtex
+ dev-tex/latexmk
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-xetex
+ media-fonts/freefont
+ )
+"
+
+DOCS=( CODE_OF_CONDUCT.md CONTRIBUTING.md CREDITS INSTALL.md README.md )
+
+src_configure() {
+ local myconf=(
+ -prefix /usr
+ -libdir /usr/$(get_libdir)/coq
+ -mandir /usr/share/man
+ -docdir /usr/share/doc/${PF}
+ -datadir /usr/share/coq
+ -configdir /etc/xdg/${PN}
+ -with-doc $(usex doc)
+ )
+
+ use debug && myconf+=( -debug )
+ use ocamlopt || myconf+=( -byte-only )
+
+ if use gtk ; then
+ if use ocamlopt ; then
+ myconf+=( -coqide opt )
+ else
+ myconf+=( -coqide byte )
+ fi
+ else
+ myconf+=( -coqide no )
+ fi
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+
+ echo "Configure options: ${myconf[@]}"
+ sh ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" VERBOSE=1 COQ_USE_DUNE="" world
+}
+
+src_test() {
+ emake STRIP="true" VERBOSE=1 COQ_USE_DUNE="" check
+}
+
+src_install() {
+ local sym
+ local syms=( coq-core coqide-server )
+
+ emake STRIP="true" VERBOSE=1 COQ_USE_DUNE="" DESTDIR="${D}" install-library
+ dune-install coq-core coqide-server
+
+ if use gtk ; then
+ dune-install coqide
+ make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+ syms+=( coqide )
+ fi
+
+ use doc && emake DESTDIR="${D}" install-doc-all
+ einstalldocs
+
+ # Dune installs into /usr/<libdir>/ocaml/<coq> but
+ # Coq wants /usr/<libdir>/<coq> ; symlink those directories
+ for sym in ${syms[@]} ; do
+ dosym $(ocamlc -where)/${sym} /usr/$(get_libdir)/${sym}
+ done
+}