summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-08 00:37:08 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-08 00:37:08 +0100
commitcc34d8bca43d2708c1cd5865712d5da660ff9a0b (patch)
treef11d22c7a86d88f216d66337b36ce491eda4b28a /sci-mathematics/rngstreams
parentdev-python/pyhamcrest-1.9.0-r1: add ~mips (diff)
downloadgentoo-cc34d8bca43d2708c1cd5865712d5da660ff9a0b.tar.gz
gentoo-cc34d8bca43d2708c1cd5865712d5da660ff9a0b.tar.bz2
gentoo-cc34d8bca43d2708c1cd5865712d5da660ff9a0b.zip
sci-mathematics/rngstreams: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics/rngstreams')
-rw-r--r--sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild32
1 files changed, 22 insertions, 10 deletions
diff --git a/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
index 2ea39b2a42f1..cf74c8bf763f 100644
--- a/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
+++ b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
@@ -1,24 +1,36 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools-utils
+inherit out-of-source
DESCRIPTION="Multiple independent streams of pseudo-random numbers"
HOMEPAGE="http://statmath.wu.ac.at/software/RngStreams/"
-SRC_URI="${HOMEPAGE}${P}.tar.gz"
+SRC_URI="http://statmath.wu.ac.at/software/RngStreams/${P}.tar.gz"
LICENSE="GPL-3"
-SLOT=0
+SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
+
+my_src_configure() {
+ econf --enable-shared --disable-static
+}
+
+my_src_install_all() {
+ if use doc; then
+ HTML_DOCS=( doc/rngstreams.html/. )
+ dodoc doc/${PN}.pdf
+ fi
+ einstalldocs
-src_install() {
- autotools-utils_src_install
- use doc && dohtml -r doc/rngstreams.html/* && dodoc doc/${PN}.pdf
if use examples; then
- rm examples/Makefile*
+ rm examples/Makefile* || die
dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
fi
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}