summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-26 10:43:50 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-26 10:44:12 +0100
commitcb54986d41de16df0fead12aa8323b130c81e01b (patch)
tree1bae657b0a41a6968329c5268d21293dacf237f3 /sci-mathematics/metamath
parentdev-java/pdfbox: Stabilize 2.0.24 amd64, #824042 (diff)
downloadgentoo-cb54986d41de16df0fead12aa8323b130c81e01b.tar.gz
gentoo-cb54986d41de16df0fead12aa8323b130c81e01b.tar.bz2
gentoo-cb54986d41de16df0fead12aa8323b130c81e01b.zip
sci-mathematics/metamath: new package; add version 0.198
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/metamath')
-rw-r--r--sci-mathematics/metamath/Manifest1
-rw-r--r--sci-mathematics/metamath/files/dont_force_optimize.patch16
-rw-r--r--sci-mathematics/metamath/metadata.xml18
-rw-r--r--sci-mathematics/metamath/metamath-0.198.ebuild28
4 files changed, 63 insertions, 0 deletions
diff --git a/sci-mathematics/metamath/Manifest b/sci-mathematics/metamath/Manifest
new file mode 100644
index 000000000000..32df01b83835
--- /dev/null
+++ b/sci-mathematics/metamath/Manifest
@@ -0,0 +1 @@
+DIST metamath-0.198.tar.gz 468593 BLAKE2B 030bc61f5d8f0c02d473fcd2802b3411c96eff04f7144b966f1f098aec3a65218137228f4d97ba96aaa190386802db00865b9e997b399ce06b19d421c335f2bf SHA512 607c0a8208b9414b36bf82a1fcb0b826e9bfa4cbcec0337be58f3e890b91473649b115403227f440b9774e5653434ffdf09f0ab82c2f5af59eac0d11b9d09942
diff --git a/sci-mathematics/metamath/files/dont_force_optimize.patch b/sci-mathematics/metamath/files/dont_force_optimize.patch
new file mode 100644
index 000000000000..548b0042ecef
--- /dev/null
+++ b/sci-mathematics/metamath/files/dont_force_optimize.patch
@@ -0,0 +1,16 @@
+index 263d3d8..68a8fea 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -45,11 +45,9 @@ int f() {
+
+ # Try to optimize.
+ AC_MSG_CHECKING([[for optimization flags]])
+-new_CFLAGS="-O3 -funroll-loops -finline-functions -fomit-frame-pointer"
++new_CFLAGS=""
+ saved_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $new_CFLAGS"
+-# Remove any existing "-O2", or it will override what we're doing.
+-CFLAGS=$( printf "%s" "$CFLAGS" | sed -e 's/ -O2/ /' )
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([[
+ #include <stdio.h>
diff --git a/sci-mathematics/metamath/metadata.xml b/sci-mathematics/metamath/metadata.xml
new file mode 100644
index 000000000000..824d79b7b66d
--- /dev/null
+++ b/sci-mathematics/metamath/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription lang="en">
+ Metamath is a tiny language that can express theorems in abstract
+ mathematics, accompanied by proofs that can be verified by a computer
+ program.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/metamath/metamath-exe/issues</bugs-to>
+ <remote-id type="github">metamath/metamath-exe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/metamath/metamath-0.198.ebuild b/sci-mathematics/metamath/metamath-0.198.ebuild
new file mode 100644
index 000000000000..4660a7b0656e
--- /dev/null
+++ b/sci-mathematics/metamath/metamath-0.198.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Proof verifier based on a minimalistic formalism"
+HOMEPAGE="http://us.metamath.org/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}-exe.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}-exe/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-exe-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/dont_force_optimize.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}