summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-03-06 08:54:19 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-03-06 08:54:19 -0500
commitdaf61b4defd22c00ad48673a834a0e706f2c4c4a (patch)
tree76be74000599e4b93d6f58161f35e19b5bccf61f /sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild
parentsys-kernel/vanilla-kernel: Remove old (diff)
downloadgentoo-daf61b4defd22c00ad48673a834a0e706f2c4c4a.tar.gz
gentoo-daf61b4defd22c00ad48673a834a0e706f2c4c4a.tar.bz2
gentoo-daf61b4defd22c00ad48673a834a0e706f2c4c4a.zip
sci-mathematics/gp2c: new version 0.0.11.3.
Upstream bugfix release gp2c-0.0.11pl3. The most interesting thing here Gentoo-wise is support for gcc-10.x (-fno-common). Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild')
-rw-r--r--sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild b/sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild
new file mode 100644
index 000000000000..b7314146b675
--- /dev/null
+++ b/sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-"$(ver_rs 3 'pl')
+DESCRIPTION="A GP to C translator"
+HOMEPAGE="http://pari.math.u-bordeaux.fr/"
+SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/GP2C/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Perl is run on the build host to compile the descriptions in desc/,
+# see for example desc/Makefile.am.
+BDEPEND="dev-lang/perl"
+
+# This is the first version of pari to put pari.cfg where we expect it.
+DEPEND=">=sci-mathematics/pari-2.11.2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf --with-paricfg="${EPREFIX}/usr/share/pari/pari.cfg"
+}