summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:14:08 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:25 +0000
commitfa6cb89a25eab00ee9803ac39c14c0493edf22be (patch)
treee4503546644c0814642bc00b4021bf52e7186d68 /sci-libs
parentsci-chemistry/theseus: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-fa6cb89a25eab00ee9803ac39c14c0493edf22be.tar.gz
gentoo-fa6cb89a25eab00ee9803ac39c14c0493edf22be.tar.bz2
gentoo-fa6cb89a25eab00ee9803ac39c14c0493edf22be.zip
sci-libs/tensorflow: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/tensorflow/tensorflow-2.4.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-libs/tensorflow/tensorflow-2.4.0.ebuild b/sci-libs/tensorflow/tensorflow-2.4.0.ebuild
index 54194fd4e24d..752cc4915648 100644
--- a/sci-libs/tensorflow/tensorflow-2.4.0.ebuild
+++ b/sci-libs/tensorflow/tensorflow-2.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -303,7 +303,7 @@ src_configure() {
echo 'build --config=noaws --config=nohdfs' >> .bazelrc || die
echo 'build --define tensorflow_mkldnn_contraction_kernel=0' >> .bazelrc || die
- for cflag in $(pkg-config jsoncpp --cflags)
+ for cflag in $($(tc-getPKG_CONFIG) jsoncpp --cflags)
do
echo "build --copt=\"$cflag\"" >> .bazelrc || die
echo "build --host_copt=\"$cflag\"" >> .bazelrc || die
@@ -385,7 +385,7 @@ src_install() {
doins -r bazel-bin/tensorflow/include/*
einfo "Installing libs"
- # Generate pkg-config file
+ # Generate $(tc-getPKG_CONFIG) file
${PN}/c/generate-pc.sh --prefix="${EPREFIX}"/usr --libdir=$(get_libdir) --version=${MY_PV} || die
insinto /usr/$(get_libdir)/pkgconfig
doins ${PN}.pc ${PN}_cc.pc