summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-13 03:53:49 +0000
committerSam James <sam@gentoo.org>2022-01-13 03:56:01 +0000
commitc10ce89a8b65d0927d26c77dacd7d54e297ed7d7 (patch)
tree1a6f903ed5a290ecb9272c237beb6b6c80b7ed15 /sci-libs
parentsys-apps/keyutils: Stabilize 1.6.3 ppc64, #789837 (diff)
downloadgentoo-c10ce89a8b65d0927d26c77dacd7d54e297ed7d7.tar.gz
gentoo-c10ce89a8b65d0927d26c77dacd7d54e297ed7d7.tar.bz2
gentoo-c10ce89a8b65d0927d26c77dacd7d54e297ed7d7.zip
sci-libs/netcdf-fortran: add 4.5.4
Drops Fortran flag workaround: https://github.com/Unidata/netcdf-fortran/commit/846ec7ac1d1eb552d319ce51fd70b832f6fcb347 Bug: https://github.com/Unidata/netcdf-fortran/pull/316 Bug: https://bugs.gentoo.org/723274 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/netcdf-fortran/Manifest1
-rw-r--r--sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/netcdf-fortran/Manifest b/sci-libs/netcdf-fortran/Manifest
index 5f10215d3ab5..3555cb2afe78 100644
--- a/sci-libs/netcdf-fortran/Manifest
+++ b/sci-libs/netcdf-fortran/Manifest
@@ -1 +1,2 @@
DIST netcdf-fortran-4.5.3.tar.gz 1805683 BLAKE2B f32a36a77872e039a0c03a1f1ccdbb00761309dc7d255a1203b0a1971464e75d87f56230f28a5d5928ca3e7e388f52c4622836c2cea3d35b286161b8044e375b SHA512 fe4b2f6f8c44bf4fdeebe3cbd57ee44ccee15a70075428bb68f0d33b70f9291b68b542965634a27fb4be5a59c756d672a3d264f2628391861edb98a244e072b4
+DIST netcdf-fortran-4.5.4.tar.gz 2011867 BLAKE2B bc98522be63c705193a22ce877c41abdc064a05afab2186891d8a0bbe9da8f0ba3f7eae6610e8b4e006b26ad8e3ea5fd8d57349054949a38f3a2fd9dfefb85c5 SHA512 a704f6483f2c8b8bf2353615a3e4b784294bd790588cfc13193c617e776e330edb17fa16da69e1a0b6c767308992321e01399ba2067c32f6ae6b3cb9ff72c3ee
diff --git a/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild b/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild
new file mode 100644
index 000000000000..49803dfd5170
--- /dev/null
+++ b/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_STANDARD="77 90"
+
+inherit autotools fortran-2 flag-o-matic
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://github.com/Unidata/netcdf-fortran/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0/7"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+
+RDEPEND="sci-libs/netcdf"
+DEPEND="${RDEPEND}
+ dev-lang/cfortran"
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-valgrind \
+ --with-temp-large="${T}" \
+ --disable-dot \
+ $(use_enable doc doxygen) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use examples && dodoc -r examples
+ find "${ED}" -name '*.la' -delete || die
+}