summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-01-12 14:40:39 +0000
committerSam James <sam@gentoo.org>2024-03-08 19:22:08 +0000
commitb97cb0c43570576ff766afedc0995c04a60dfdde (patch)
tree77f26811872acdab634beff7875b58d6175e5833 /sci-libs
parentsci-libs/rocThrust: set include path in cmake config to correct one (diff)
downloadgentoo-b97cb0c43570576ff766afedc0995c04a60dfdde.tar.gz
gentoo-b97cb0c43570576ff766afedc0995c04a60dfdde.tar.bz2
gentoo-b97cb0c43570576ff766afedc0995c04a60dfdde.zip
sci-libs/hipCUB: install cmake files to /usr/lib64/cmake, not /usr/lib/cmake
Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hipCUB/hipCUB-5.7.1-r1.ebuild (renamed from sci-libs/hipCUB/hipCUB-5.7.1.ebuild)28
1 files changed, 6 insertions, 22 deletions
diff --git a/sci-libs/hipCUB/hipCUB-5.7.1.ebuild b/sci-libs/hipCUB/hipCUB-5.7.1-r1.ebuild
index 0674d33b6ed5..8ff00b145b09 100644
--- a/sci-libs/hipCUB/hipCUB-5.7.1.ebuild
+++ b/sci-libs/hipCUB/hipCUB-5.7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,28 +27,12 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/hipCUB-rocm-${PV}"
-# src_prepare() {
-# sed -e "/PREFIX hipcub/d" \
-# -e "/DESTINATION/s:hipcub/include/:include/:" \
-# -e "/rocm_install_symlink_subdir(hipcub)/d" \
-# -e "/<INSTALL_INTERFACE/s:hipcub/include/:include/hipcub/:" -i hipcub/CMakeLists.txt || die
+src_prepare() {
+ sed -e "s:set(ROCM_INSTALL_LIBDIR lib):set(ROCM_INSTALL_LIBDIR $(get_libdir)):" \
+ -i cmake/ROCMExportTargetsHeaderOnly.cmake || die
-# sed -e "s:\${ROCM_INSTALL_LIBDIR}:\${CMAKE_INSTALL_LIBDIR}:" -i cmake/ROCMExportTargetsHeaderOnly.cmake || die
-
-# # disable downloading googletest and googlebenchmark
-# sed -r -e '/Downloading/{:a;N;/\n *\)$/!ba; d}' -i cmake/Dependencies.cmake || die
-
-# # remove GIT dependency
-# sed -r -e '/find_package\(Git/{:a;N;/\nendif/!ba; d}' -i cmake/Dependencies.cmake || die
-
-# if use benchmark; then
-# sed -e "/get_filename_component/s,\${BENCHMARK_SOURCE},${PN}_\${BENCHMARK_SOURCE}," \
-# -e "/add_executable/a\ install(TARGETS \${BENCHMARK_TARGET})" -i benchmark/CMakeLists.txt || die
-# fi
-
-# eapply_user
-# cmake_src_prepare
-# }
+ cmake_src_prepare
+}
src_configure() {
addpredict /dev/kfd