summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-08-07 12:08:09 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-08-07 12:35:44 -0400
commitae6b26acdfebbf19c8f8855a63fd86bab3e63b5d (patch)
treea75b2236811d3654b48f66907cc8bfc33f85cc02 /sci-libs
parentapp-admin/calamares: Fix odd patch filename (diff)
downloadgentoo-ae6b26acdfebbf19c8f8855a63fd86bab3e63b5d.tar.gz
gentoo-ae6b26acdfebbf19c8f8855a63fd86bab3e63b5d.tar.bz2
gentoo-ae6b26acdfebbf19c8f8855a63fd86bab3e63b5d.zip
sci-libs/givaro: new revision to eliminate -fabi-version=6.
This is just a quick hack directly to the ./configure script to ensure that the current version of givaro doesn't erroneously detect gcc-4.x where none exists. A real fix is already upstreamed, but not in a release, and is not easy to backport. Bug: https://bugs.gentoo.org/741434 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/givaro/files/givaro-4.1.1-gcc-10.patch36
-rw-r--r--sci-libs/givaro/givaro-4.1.1-r2.ebuild56
2 files changed, 92 insertions, 0 deletions
diff --git a/sci-libs/givaro/files/givaro-4.1.1-gcc-10.patch b/sci-libs/givaro/files/givaro-4.1.1-gcc-10.patch
new file mode 100644
index 000000000000..0564c7f94fef
--- /dev/null
+++ b/sci-libs/givaro/files/givaro-4.1.1-gcc-10.patch
@@ -0,0 +1,36 @@
+From 5ba9fa4930b347aea8817da444bea5a88971079a Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sat, 7 Aug 2021 11:43:29 -0400
+Subject: [PATCH 1/1] configure: hack out old GCC-4.x test.
+
+The Givaro ./configure script fails to detect modern versions of GCC,
+instead deciding that they must be gcc-4.8. As a result, we wind up
+with "-fabi-version=6" in CXXFLAGS, which then gets propagated to
+users of "givaro-config --cflags", like fflas-ffpack.
+
+This is already fixed upstream, but not in a release, and not in a
+way that I care to backport. Here we just hack the configure script
+directly since the change is so trivial.
+---
+ configure | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/configure b/configure
+index 1eb75b0..f3bbb52 100755
+--- a/configure
++++ b/configure
+@@ -17172,11 +17172,6 @@ fi
+
+ echo "-----------------------------------------------"
+
+-if test "x$CCNAM" = "xgcc48"; then :
+- REQUIRED_FLAGS="${REQUIRED_FLAGS} -fabi-version=6"
+-fi
+-
+-
+
+ # Machine characteristics
+
+--
+2.31.1
+
diff --git a/sci-libs/givaro/givaro-4.1.1-r2.ebuild b/sci-libs/givaro/givaro-4.1.1-r2.ebuild
new file mode 100644
index 000000000000..2e76210dd2e3
--- /dev/null
+++ b/sci-libs/givaro/givaro-4.1.1-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ library for arithmetic and algebraic computations"
+HOMEPAGE="https://casys.gricad-pages.univ-grenoble-alpes.fr/givaro/"
+SRC_URI="https://github.com/linbox-team/givaro/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="CeCILL-B"
+SLOT="0/9"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 doc static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+"
+DEPEND="dev-libs/gmp:0[cxx(+)]"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+PATCHES=( "${FILESDIR}/givaro-4.1.1-gcc-10.patch" )
+
+src_configure() {
+ # Passing "--disable-doc" also accidentally enables building
+ # the documentation, so we can't just $(use_enable doc) here.
+ # https://github.com/linbox-team/givaro/issues/148
+ econf \
+ $(usex doc --enable-doc "" "" "") \
+ --with-docdir="/usr/share/doc/${PF}/html" \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_fma3 fma) \
+ $(use_enable cpu_flags_x86_fma4 fma4) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable cpu_flags_x86_sse3 sse3) \
+ $(use_enable cpu_flags_x86_ssse3 ssse3) \
+ $(use_enable cpu_flags_x86_sse4_1 sse41) \
+ $(use_enable cpu_flags_x86_sse4_2 sse42) \
+ $(use_enable cpu_flags_x86_avx avx) \
+ $(use_enable cpu_flags_x86_avx2 avx2)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}