summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJian Lin <jlin.gentoo@outlook.com>2021-05-10 15:30:13 +0800
committerJason Zaman <perfinion@gentoo.org>2021-06-20 15:04:43 -0700
commita99862388c0fcc72b52f87421630b8383061c317 (patch)
tree1146c21eda743fb420778840ff89b291b75e3c3e /sci-libs
parentsys-block/zram-init: bump to version 11.0 (diff)
downloadgentoo-a99862388c0fcc72b52f87421630b8383061c317.tar.gz
gentoo-a99862388c0fcc72b52f87421630b8383061c317.tar.bz2
gentoo-a99862388c0fcc72b52f87421630b8383061c317.zip
sci-libs/tensorflow: check gcc version correctly
Closes: https://bugs.gentoo.org/789270 Closes: https://github.com/gentoo/gentoo/pull/20750 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Jian Lin <jlin.gentoo@outlook.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/tensorflow/tensorflow-2.4.0.ebuild2
-rw-r--r--sci-libs/tensorflow/tensorflow-2.5.0.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sci-libs/tensorflow/tensorflow-2.4.0.ebuild b/sci-libs/tensorflow/tensorflow-2.4.0.ebuild
index f9f852726c0c..7e6fd9bc4b8f 100644
--- a/sci-libs/tensorflow/tensorflow-2.4.0.ebuild
+++ b/sci-libs/tensorflow/tensorflow-2.4.0.ebuild
@@ -233,7 +233,7 @@ src_configure() {
einfo "Setting CUDA version: $TF_CUDA_VERSION"
einfo "Setting CUDNN version: $TF_CUDNN_VERSION"
- if [[ *$(gcc-version)* != $(cuda-config -s) ]]; then
+ if [[ $(cuda-config -s) != *$(gcc-version)* ]]; then
ewarn "TensorFlow is being built with Nvidia CUDA support. Your default compiler"
ewarn "version is not supported by the currently installed CUDA. TensorFlow will"
ewarn "instead be compiled using: ${GCC_HOST_COMPILER_PATH}."
diff --git a/sci-libs/tensorflow/tensorflow-2.5.0.ebuild b/sci-libs/tensorflow/tensorflow-2.5.0.ebuild
index f6bc650064fe..3e640b929a91 100644
--- a/sci-libs/tensorflow/tensorflow-2.5.0.ebuild
+++ b/sci-libs/tensorflow/tensorflow-2.5.0.ebuild
@@ -238,7 +238,7 @@ src_configure() {
einfo "Setting CUDA version: $TF_CUDA_VERSION"
einfo "Setting CUDNN version: $TF_CUDNN_VERSION"
- if [[ *$(gcc-version)* != $(cuda-config -s) ]]; then
+ if [[ $(cuda-config -s) != *$(gcc-version)* ]]; then
ewarn "TensorFlow is being built with Nvidia CUDA support. Your default compiler"
ewarn "version is not supported by the currently installed CUDA. TensorFlow will"
ewarn "instead be compiled using: ${GCC_HOST_COMPILER_PATH}."