summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2021-12-21 11:03:51 +0800
committerBenda Xu <heroxbd@gentoo.org>2022-03-20 16:57:00 +0800
commit756f565826e38263a085aba91b4d0d27954f26c3 (patch)
tree613c7e3b7882ee2d91fd0daf6692ee8a896e336b /sci-libs
parentsci-libs/rocBLAS-4.3.0: re-enable Tensile library (diff)
downloadgentoo-756f565826e38263a085aba91b4d0d27954f26c3.tar.gz
gentoo-756f565826e38263a085aba91b4d0d27954f26c3.tar.bz2
gentoo-756f565826e38263a085aba91b4d0d27954f26c3.zip
sci-libs/rocFFT: remove unused cmake variable
__skip_rocmclang is used to avoid configuration error for cmake-3.21.(1|2), which don't exist among ebuilds anymore, so this flag is not recognized. Closes: https://github.com/gentoo/gentoo/pull/23446 Closes: https://bugs.gentoo.org/829326 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/rocFFT/rocFFT-4.3.0-r1.ebuild (renamed from sci-libs/rocFFT/rocFFT-4.3.0.ebuild)6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-libs/rocFFT/rocFFT-4.3.0.ebuild b/sci-libs/rocFFT/rocFFT-4.3.0-r1.ebuild
index 3666f751adf2..5ebefcf5435f 100644
--- a/sci-libs/rocFFT/rocFFT-4.3.0.ebuild
+++ b/sci-libs/rocFFT/rocFFT-4.3.0-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7..10} )
-inherit cmake check-reqs flag-o-matic multiprocessing python-any-r1
+inherit cmake check-reqs multiprocessing python-any-r1
DESCRIPTION="Next generation FFT implementation for ROCm"
HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocFFT"
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}
BDEPEND="
test? ( dev-cpp/gtest dev-libs/boost
>=sci-libs/fftw-3
+ >=dev-util/cmake-3.22
)"
CHECKREQS_DISK_BUILD="7G"
@@ -87,7 +88,6 @@ src_configure() {
-DBUILD_CLIENTS_TESTS=$(usex test ON OFF)
-DBUILD_CLIENTS_SELFTEST=OFF # rocFFT-4.3.0 self test fails. See https://github.com/ROCmSoftwarePlatform/rocFFT/issues/324. Enable it for rocFFT-4.4
${AMDGPU_TARGETS+-DAMDGPU_TARGETS="${AMDGPU_TARGETS}"}
- -D__skip_rocmclang="ON" ## fix cmake-3.21 configuration issue caused by officialy support programming language "HIP"
)
cmake_src_configure