summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 22:20:01 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 23:40:03 +0100
commit615037c94596ca6ac97d5dc8be7c08ead842dc67 (patch)
tree49bed75328203c8cb1434738507401623febaf66 /sci-libs
parentsci-libs/liborigin: fix .pc file (diff)
downloadgentoo-615037c94596ca6ac97d5dc8be7c08ead842dc67.tar.gz
gentoo-615037c94596ca6ac97d5dc8be7c08ead842dc67.tar.bz2
gentoo-615037c94596ca6ac97d5dc8be7c08ead842dc67.zip
sci-libs/liborigin: fix header location in pc file
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/liborigin/files/liborigin-3.0.1_p20210828-buildsystem.patch16
1 files changed, 13 insertions, 3 deletions
diff --git a/sci-libs/liborigin/files/liborigin-3.0.1_p20210828-buildsystem.patch b/sci-libs/liborigin/files/liborigin-3.0.1_p20210828-buildsystem.patch
index 43cf499bb7a8..8ad6fd432abe 100644
--- a/sci-libs/liborigin/files/liborigin-3.0.1_p20210828-buildsystem.patch
+++ b/sci-libs/liborigin/files/liborigin-3.0.1_p20210828-buildsystem.patch
@@ -1,5 +1,5 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a8e5914..8eb13c2 100644
+index a8e5914..6401a30 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,7 +41,6 @@ set (devel-headers
@@ -10,7 +10,15 @@ index a8e5914..8eb13c2 100644
)
# allow for installation of individual targets
-@@ -74,11 +73,13 @@ if( "${CMAKE_SOURCE_DIR}" STREQUAL "${PROJECT_SOURCE_DIR}" )
+@@ -65,6 +64,7 @@ add_library (origin_static STATIC $<TARGET_OBJECTS:origin>)
+ set_target_properties(origin_static PROPERTIES OUTPUT_NAME "origin" )
+
+ if( "${CMAKE_SOURCE_DIR}" STREQUAL "${PROJECT_SOURCE_DIR}" )
++ include(GNUInstallDirs)
+
+ # Shared library
+ add_library( origin_shared SHARED $<TARGET_OBJECTS:origin>)
+@@ -74,13 +74,14 @@ if( "${CMAKE_SOURCE_DIR}" STREQUAL "${PROJECT_SOURCE_DIR}" )
SOVERSION ${PROJECT_VERSION_MAJOR}
)
# Generate a pkg-config file matching this config
@@ -23,8 +31,10 @@ index a8e5914..8eb13c2 100644
target_link_libraries (opj2dat origin_static)
+ endif ()
- include(GNUInstallDirs)
+- include(GNUInstallDirs)
# install libraries
+ install( TARGETS origin_shared origin_static
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
@@ -92,7 +93,9 @@ if( "${CMAKE_SOURCE_DIR}" STREQUAL "${PROJECT_SOURCE_DIR}" )
# install pkg-config file
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/liborigin.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)