summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-07-20 17:33:11 +0000
committerSam James <sam@gentoo.org>2024-09-09 19:15:17 +0100
commit49badac556ce194ade8e48f893f205b967c67fcd (patch)
tree1ce3711f7ea85f54bcc8c5a4f2e7f92ec57ef74f /sci-libs
parentsci-libs/rocBLAS: strip unsupported flags for potentially switched compiler (diff)
downloadgentoo-49badac556ce194ade8e48f893f205b967c67fcd.tar.gz
gentoo-49badac556ce194ade8e48f893f205b967c67fcd.tar.bz2
gentoo-49badac556ce194ade8e48f893f205b967c67fcd.zip
sci-libs/rocFFT: strip unsupported flags for potentially switched compiler
Bug: https://bugs.gentoo.org/936099 Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/rocFFT/rocFFT-6.1.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-libs/rocFFT/rocFFT-6.1.1.ebuild b/sci-libs/rocFFT/rocFFT-6.1.1.ebuild
index 4eef4ea268dc..99709902c496 100644
--- a/sci-libs/rocFFT/rocFFT-6.1.1.ebuild
+++ b/sci-libs/rocFFT/rocFFT-6.1.1.ebuild
@@ -101,6 +101,8 @@ src_prepare() {
}
src_configure() {
+ rocm_use_hipcc
+
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
-DAMDGPU_TARGETS="$(get_amdgpu_flags)"
@@ -112,7 +114,7 @@ src_configure() {
-DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
)
- CXX=hipcc cmake_src_configure
+ cmake_src_configure
}
src_test() {