summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-16 21:02:37 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-16 21:05:01 +0300
commit0993fd6e92d5887f85e396511d29d4708626b25a (patch)
tree8f2141ceb465dfd5589d4a514e8bf5ac88570520 /sci-libs
parentmedia-gfx/sane-airscan: add 0.99.29 (diff)
downloadgentoo-0993fd6e92d5887f85e396511d29d4708626b25a.tar.gz
gentoo-0993fd6e92d5887f85e396511d29d4708626b25a.tar.bz2
gentoo-0993fd6e92d5887f85e396511d29d4708626b25a.zip
sci-libs/beagle: treeclean
Bug: https://bugs.gentoo.org/862669 Bug: https://bugs.gentoo.org/890423 Bug: https://bugs.gentoo.org/873262 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/beagle/Manifest1
-rw-r--r--sci-libs/beagle/beagle-3.0.3-r2.ebuild56
-rw-r--r--sci-libs/beagle/files/beagle-3.0.3-fix-c++14.patch30
-rw-r--r--sci-libs/beagle/files/beagle-3.0.3-gcc43.patch89
-rw-r--r--sci-libs/beagle/files/beagle-3.0.3-gcc47.patch10
-rw-r--r--sci-libs/beagle/metadata.xml15
6 files changed, 0 insertions, 201 deletions
diff --git a/sci-libs/beagle/Manifest b/sci-libs/beagle/Manifest
deleted file mode 100644
index 2f7030591c33..000000000000
--- a/sci-libs/beagle/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST beagle-3.0.3.tar.gz 5002994 BLAKE2B f23c3178a52333aef0d1ba71d3a9ae240a805f016c9f619f59d76f818d9a647505af608aab2e0eb19efba6c6a3ed9d14455e03cfaa38df2b324689ba8139b849 SHA512 2f8f027f3f24d0fd287e27a80fe5b24e18550144add06fb8157dd03f734f5ce212f62889720c81fd33246fa7086e9b913802ec0c5155df5bd801c36888b346cb
diff --git a/sci-libs/beagle/beagle-3.0.3-r2.ebuild b/sci-libs/beagle/beagle-3.0.3-r2.ebuild
deleted file mode 100644
index 846df89bd57d..000000000000
--- a/sci-libs/beagle/beagle-3.0.3-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Open BEAGLE, a versatile EC/GA/GP framework"
-HOMEPAGE="https://chgagne.github.io/beagle/"
-SRC_URI="https://downloads.sourceforge.net/beagle/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples static-libs"
-
-RDEPEND="sys-libs/zlib"
-DEPEND="${RDEPEND}"
-BDEPEND="doc? ( app-text/doxygen )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.0.3-gcc43.patch"
- "${FILESDIR}/${PN}-3.0.3-gcc47.patch"
- "${FILESDIR}/${PN}-3.0.3-fix-c++14.patch"
-)
-
-src_prepare() {
- default
- sed -e "s:@LIBS@:& -lpthread:" -i PACC/Threading/Makefile.in || die
-
- # fix build with C++17, bug #898274
- sed -e "s/register //" -i PACC/Util/{MTRand.hpp,Tokenizer.cpp} || die
-}
-
-src_configure() {
- econf \
- --enable-optimization \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- default
- use doc && emake doc
-}
-
-src_install() {
- use doc && local HTML_DOCS=( refman/. )
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- default
-
- if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
- fi
-}
diff --git a/sci-libs/beagle/files/beagle-3.0.3-fix-c++14.patch b/sci-libs/beagle/files/beagle-3.0.3-fix-c++14.patch
deleted file mode 100644
index 896b58225890..000000000000
--- a/sci-libs/beagle/files/beagle-3.0.3-fix-c++14.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Fix building with C++14, where destructors are noexcept(true) by default.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=597342
-
---- a/PACC/Threading/Thread.cpp
-+++ b/PACC/Threading/Thread.cpp
-@@ -79,6 +79,9 @@
- \attention If the destructor in the derived thread class (e.g. MyThread above) does not wait for thread termination, the potential hazardous situation is that the runtime system will have deleted all of its members before calling this destructor (in C++, class destructors are called in reversed sequence). Thus, the still running thread could access deleted data members with unpredictable and unexpected results. So beware!
- */
- Threading::Thread::~Thread(void)
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
- {
- lock();
- if(mThread) {
---- a/PACC/Threading/Thread.hpp
-+++ b/PACC/Threading/Thread.hpp
-@@ -53,7 +53,11 @@
- class Thread : public Condition {
- public:
- Thread(void);
-- virtual ~Thread(void);
-+ virtual ~Thread(void)
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ ;
-
- void cancel(void);
- bool isRunning(void) const;
diff --git a/sci-libs/beagle/files/beagle-3.0.3-gcc43.patch b/sci-libs/beagle/files/beagle-3.0.3-gcc43.patch
deleted file mode 100644
index 608ce388e793..000000000000
--- a/sci-libs/beagle/files/beagle-3.0.3-gcc43.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-diff -rupN beagle-3.0.3b/PACC/Math/Matrix.cpp beagle-3.0.3/PACC/Math/Matrix.cpp
---- beagle-3.0.3b/PACC/Math/Matrix.cpp 2009-01-20 23:38:39.000000000 -0400
-+++ beagle-3.0.3/PACC/Math/Matrix.cpp 2009-01-21 00:26:46.000000000 -0400
-@@ -40,6 +40,7 @@
- #include <stdexcept>
- #include <iomanip>
- #include <cmath>
-+#include <climits>
-
- using namespace std;
- using namespace PACC;
-diff -rupN beagle-3.0.3b/PACC/Math/Vector.hpp beagle-3.0.3/PACC/Math/Vector.hpp
---- beagle-3.0.3b/PACC/Math/Vector.hpp 2009-01-20 23:38:39.000000000 -0400
-+++ beagle-3.0.3/PACC/Math/Vector.hpp 2009-01-21 00:26:29.000000000 -0400
-@@ -42,6 +42,7 @@
- #include "XML/Document.hpp"
- #include "XML/Streamer.hpp"
- #include <cmath>
-+#include <algorithm>
-
- namespace PACC {
-
-diff -rupN beagle-3.0.3b/PACC/Socket/Cafe.cpp beagle-3.0.3/PACC/Socket/Cafe.cpp
---- beagle-3.0.3b/PACC/Socket/Cafe.cpp 2009-01-20 23:38:39.000000000 -0400
-+++ beagle-3.0.3/PACC/Socket/Cafe.cpp 2009-01-21 00:31:09.000000000 -0400
-@@ -35,6 +35,7 @@
-
- #include "Socket/Cafe.hpp"
- #include <iostream>
-+#include <cstring>
-
- #ifdef WIN32
- ///////////// specifics for windows /////////////
-diff -rupN beagle-3.0.3b/PACC/Socket/Port.cpp beagle-3.0.3/PACC/Socket/Port.cpp
---- beagle-3.0.3b/PACC/Socket/Port.cpp 2009-01-20 23:38:39.000000000 -0400
-+++ beagle-3.0.3/PACC/Socket/Port.cpp 2009-01-21 00:30:54.000000000 -0400
-@@ -34,6 +34,7 @@
- */
-
- #include "Socket/Port.hpp"
-+#include <cstring>
-
- #ifdef WIN32
- ///////////// specifics for windows /////////////
-diff -rupN beagle-3.0.3b/PACC/Threading/Thread.cpp beagle-3.0.3/PACC/Threading/Thread.cpp
---- beagle-3.0.3b/PACC/Threading/Thread.cpp 2009-01-20 23:38:39.000000000 -0400
-+++ beagle-3.0.3/PACC/Threading/Thread.cpp 2009-01-21 00:28:02.000000000 -0400
-@@ -35,6 +35,7 @@
-
- #include "Threading/Thread.hpp"
- #include "Util/Assert.hpp"
-+#include <cstdlib>
-
- #ifdef WIN32
- #include <windows.h>
-diff -rupN beagle-3.0.3b/PACC/Util/SignalHandler.cpp beagle-3.0.3/PACC/Util/SignalHandler.cpp
---- beagle-3.0.3b/PACC/Util/SignalHandler.cpp 2009-01-20 23:38:39.000000000 -0400
-+++ beagle-3.0.3/PACC/Util/SignalHandler.cpp 2009-01-20 23:44:20.000000000 -0400
-@@ -37,6 +37,7 @@
- #include "Util/Assert.hpp"
- #include <signal.h>
- #include <stdexcept>
-+#include <cstdlib>
-
- using namespace std;
- using namespace PACC;
-diff -rupN beagle-3.0.3b/PACC/Util/Tokenizer.cpp beagle-3.0.3/PACC/Util/Tokenizer.cpp
---- beagle-3.0.3b/PACC/Util/Tokenizer.cpp 2009-01-20 23:38:39.000000000 -0400
-+++ beagle-3.0.3/PACC/Util/Tokenizer.cpp 2009-01-20 23:44:10.000000000 -0400
-@@ -36,6 +36,8 @@
- #include "Util/Tokenizer.hpp"
- #include "Util/Assert.hpp"
- #include <stdexcept>
-+#include <cstring>
-+#include <cstdlib>
-
- using namespace std;
- using namespace PACC;
-diff -rupN beagle-3.0.3b/PACC/XML/Node.cpp beagle-3.0.3/PACC/XML/Node.cpp
---- beagle-3.0.3b/PACC/XML/Node.cpp 2009-01-20 23:38:39.000000000 -0400
-+++ beagle-3.0.3/PACC/XML/Node.cpp 2009-01-20 23:45:09.000000000 -0400
-@@ -39,6 +39,7 @@
- #include "Util/Assert.hpp"
- #include <sstream>
- #include <stdexcept>
-+#include <cstring>
-
- using namespace std;
- using namespace PACC;
diff --git a/sci-libs/beagle/files/beagle-3.0.3-gcc47.patch b/sci-libs/beagle/files/beagle-3.0.3-gcc47.patch
deleted file mode 100644
index b74fb32b9989..000000000000
--- a/sci-libs/beagle/files/beagle-3.0.3-gcc47.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/beagle/include/beagle/RouletteT.hpp
-+++ b/beagle/include/beagle/RouletteT.hpp
-@@ -87,7 +87,7 @@
- Beagle_StackTraceBeginM();
- Beagle_AssertM(inWeight>=0.0);
- if(VectorType::empty()==false) inWeight += VectorType::back().first;
-- push_back(std::make_pair(inWeight,inValue));
-+ this->push_back(std::make_pair(inWeight,inValue));
- Beagle_StackTraceEndM("void RouletteT<T>::insert(const T& inValue, double inWeight)");
- }
diff --git a/sci-libs/beagle/metadata.xml b/sci-libs/beagle/metadata.xml
deleted file mode 100644
index 61308c44d1d4..000000000000
--- a/sci-libs/beagle/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription>
- Open BEAGLE is a C++ Evolutionary Computation (EC) framework. It provides an high-level software environment to do any kind of EC, with support for tree-based genetic programming, bit string and real-valued genetic algorithms, and evolution strategy.
- </longdescription>
- <upstream>
- <remote-id type="sourceforge">beagle</remote-id>
- <remote-id type="github">chgagne/beagle</remote-id>
- </upstream>
-</pkgmetadata>