summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-03-05 02:46:01 +0100
committerSam James <sam@gentoo.org>2022-03-05 23:56:45 +0000
commit643ee5d9612eb37bf71c05f0d08da9834acf50fa (patch)
tree58416e1fbf1d8c8628984192ced61d06988a744f /sci-libs/vtk
parentdev-ml/lablgtk: add 2.18.12 (diff)
downloadgentoo-643ee5d9612eb37bf71c05f0d08da9834acf50fa.tar.gz
gentoo-643ee5d9612eb37bf71c05f0d08da9834acf50fa.tar.bz2
gentoo-643ee5d9612eb37bf71c05f0d08da9834acf50fa.zip
sci-libs/vtk: select desired Qt version
If both, Qt5 and Qt6 are installed and found, Qt6 is preferred. The ebuild, however, does not build against Qt6. To ensure Qt5 is selected we pass VTK_QT_VERSION to cmake. Closes: https://bugs.gentoo.org/834595 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/24405 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/vtk-9.1.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sci-libs/vtk/vtk-9.1.0.ebuild b/sci-libs/vtk/vtk-9.1.0.ebuild
index ee1a824bac00..7be370c13c6a 100644
--- a/sci-libs/vtk/vtk-9.1.0.ebuild
+++ b/sci-libs/vtk/vtk-9.1.0.ebuild
@@ -457,7 +457,10 @@ src_configure() {
fi
if use qt5; then
- mycmakeargs+=( -DVTK_MODULE_ENABLE_VTK_GUISupportQt="WANT" )
+ mycmakeargs+=(
+ -DVTK_MODULE_ENABLE_VTK_GUISupportQt="WANT"
+ -DVTK_QT_VERSION="5"
+ )
if use mysql || use postgres; then
mycmakeargs+=( -DVTK_MODULE_ENABLE_VTK_GUISupportQtSQL="WANT" )
fi