summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-12-08 19:18:22 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-09 01:25:26 +0800
commita3dc69074dcad86d4c95e024d231c90c62483152 (patch)
tree806117a383dbff1baccb3314d223b0820f74ba4b /sci-libs/tensorflow/tensorflow-2.0.0.ebuild
parentsci-libs/tensorflow-estimator: bump 1.15.1 (diff)
downloadgentoo-a3dc69074dcad86d4c95e024d231c90c62483152.tar.gz
gentoo-a3dc69074dcad86d4c95e024d231c90c62483152.tar.bz2
gentoo-a3dc69074dcad86d4c95e024d231c90c62483152.zip
sci-libs/tensorflow: fix bazel, jsoncpp deps
Also add a message about setting cuda compute capability Closes: https://bugs.gentoo.org/695428 Closes: https://bugs.gentoo.org/697864 Closes: https://bugs.gentoo.org/702222 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-libs/tensorflow/tensorflow-2.0.0.ebuild')
-rw-r--r--sci-libs/tensorflow/tensorflow-2.0.0.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/sci-libs/tensorflow/tensorflow-2.0.0.ebuild b/sci-libs/tensorflow/tensorflow-2.0.0.ebuild
index 4c12428e6e42..e70af54032ea 100644
--- a/sci-libs/tensorflow/tensorflow-2.0.0.ebuild
+++ b/sci-libs/tensorflow/tensorflow-2.0.0.ebuild
@@ -56,8 +56,9 @@ RDEPEND="
app-arch/snappy
dev-db/lmdb
dev-db/sqlite
+ dev-libs/double-conversion
dev-libs/icu
- >=dev-libs/jsoncpp-1.9
+ ~dev-libs/jsoncpp-1.9.1
dev-libs/libpcre
dev-libs/nsync
dev-libs/openssl:0=
@@ -108,7 +109,6 @@ BDEPEND="
dev-python/cython
|| (
=dev-util/bazel-0.24*
- =dev-util/bazel-0.26*
=dev-util/bazel-0.27*
)
cuda? (
@@ -207,6 +207,18 @@ src_configure() {
export TF_CUDNN_VERSION="$(cuda_cudnn_version)"
einfo "Setting CUDA version: $TF_CUDA_VERSION"
einfo "Setting CUDNN version: $TF_CUDNN_VERSION"
+
+ if [[ -z "$TF_CUDA_COMPUTE_CAPABILITIES" ]]; then
+ ewarn "WARNING: Tensorflow is being built with its default CUDA compute capabilities: 3.5 and 7.0."
+ ewarn "These may not be optimal for your GPU."
+ ewarn ""
+ ewarn "To configure Tensorflow with the CUDA compute capability that is optimal for your GPU,"
+ ewarn "set TF_CUDA_COMPUTE_CAPABILITIES in your make.conf, and re-emerge tensorflow."
+ ewarn "For example, to use CUDA capability 7.5 & 3.5, add: TF_CUDA_COMPUTE_CAPABILITIES=7.5,3.5"
+ ewarn ""
+ ewarn "You can look up your GPU's CUDA compute capability at https://developer.nvidia.com/cuda-gpus"
+ ewarn "or by running /opt/cuda/extras/demo_suite/deviceQuery | grep 'CUDA Capability'"
+ fi
fi
local SYSLIBS=(