summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-02-01 22:49:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-02-01 22:55:03 +0100
commit9e4c143c8b8d383b70fd127ab5e71cd90f254ae7 (patch)
tree8f1c4af1d528babd38dee89a0baccb300b5c5c5e /sci-libs/stellarsolver
parentsci-astronomy/kstars: Restrict to Qt5-based <sci-libs/stellarsolver-2.6-r10 (diff)
downloadgentoo-9e4c143c8b8d383b70fd127ab5e71cd90f254ae7.tar.gz
gentoo-9e4c143c8b8d383b70fd127ab5e71cd90f254ae7.tar.bz2
gentoo-9e4c143c8b8d383b70fd127ab5e71cd90f254ae7.zip
sci-libs/stellarsolver: Switch to Qt6
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/stellarsolver')
-rw-r--r--sci-libs/stellarsolver/stellarsolver-2.6-r10.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/stellarsolver/stellarsolver-2.6-r10.ebuild b/sci-libs/stellarsolver/stellarsolver-2.6-r10.ebuild
new file mode 100644
index 000000000000..8df7b5ad70f8
--- /dev/null
+++ b/sci-libs/stellarsolver/stellarsolver-2.6-r10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Cross-platform Sextractor and Astrometry.net-Based internal astrometric solver"
+HOMEPAGE="https://github.com/rlancaste/stellarsolver"
+SRC_URI="https://github.com/rlancaste/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtbase:6[concurrent,gui,network,widgets]
+ sci-libs/cfitsio:=
+ sci-libs/gsl:=
+ sci-astronomy/wcslib:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # bug #862930
+ filter-lto
+
+ local mycmakeargs=(
+ -DUSE_QT5=OFF
+ -DBUILD_CLI=OFF # nothing is installed (yet?)
+ )
+
+ cmake_src_configure
+}