summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-03-14 18:30:01 +0100
committerPacho Ramos <pacho@gentoo.org>2020-03-14 18:32:05 +0100
commit184d26371cade2dc4a4913fb5da3b76ef3cd2d15 (patch)
tree9658790d1e4947b1b6f7fe9708c7764491ca233d /sci-libs/spglib/spglib-1.14.1.ebuild
parentmedia-sound/xmms2: install uncompressed manpages (diff)
downloadgentoo-184d26371cade2dc4a4913fb5da3b76ef3cd2d15.tar.gz
gentoo-184d26371cade2dc4a4913fb5da3b76ef3cd2d15.tar.bz2
gentoo-184d26371cade2dc4a4913fb5da3b76ef3cd2d15.zip
sci-libs/spglib: Add spglib, needed by Avogadro2
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-libs/spglib/spglib-1.14.1.ebuild')
-rw-r--r--sci-libs/spglib/spglib-1.14.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/spglib/spglib-1.14.1.ebuild b/sci-libs/spglib/spglib-1.14.1.ebuild
new file mode 100644
index 000000000000..3471996ebea3
--- /dev/null
+++ b/sci-libs/spglib/spglib-1.14.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Spglib is a C library for finding and handling crystal symmetries"
+HOMEPAGE="https://atztogo.github.io/spglib/"
+SRC_URI="https://github.com/atztogo/spglib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+BDEPEND=""
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}