summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-20 19:59:19 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-20 20:01:32 +0200
commit517f159ae645ae96e785c5b5bee9e90aaa8bbcfa (patch)
treeecdcf8619960c471e27f33f37207def150ceecb2 /sci-libs/rtree/rtree-1.0.0.ebuild
parentdev-python/pyxdg: update EAPI 7 -> 8, py3.11, PEP517, nose -> pytest (diff)
downloadgentoo-517f159ae645ae96e785c5b5bee9e90aaa8bbcfa.tar.gz
gentoo-517f159ae645ae96e785c5b5bee9e90aaa8bbcfa.tar.bz2
gentoo-517f159ae645ae96e785c5b5bee9e90aaa8bbcfa.zip
sci-libs/rtree: add 1.0.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs/rtree/rtree-1.0.0.ebuild')
-rw-r--r--sci-libs/rtree/rtree-1.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/rtree/rtree-1.0.0.ebuild b/sci-libs/rtree/rtree-1.0.0.ebuild
new file mode 100644
index 000000000000..928981fc2086
--- /dev/null
+++ b/sci-libs/rtree/rtree-1.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_PN="Rtree"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="R-Tree spatial index for Python GIS"
+HOMEPAGE="https://rtree.readthedocs.io"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ sci-libs/libspatialindex
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+BDEPEND="
+ test? ( dev-python/numpy[${PYTHON_USEDEP}] )
+"