summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2022-05-04 15:53:54 +0800
committerBenda Xu <heroxbd@gentoo.org>2022-06-20 19:51:34 +0800
commitde8cf511f58071e19f69e47947e5946ad864943f (patch)
tree442aff9cf36c9d20bd9db0a85e08b83eecf38f1e /sci-libs/rocSPARSE
parentmedia-sound/denonavr-cli: New package, v1 (diff)
downloadgentoo-de8cf511f58071e19f69e47947e5946ad864943f.tar.gz
gentoo-de8cf511f58071e19f69e47947e5946ad864943f.tar.bz2
gentoo-de8cf511f58071e19f69e47947e5946ad864943f.zip
sci-libs/rocSPARSE: fix data prepare under EAPI8
In EAPI=7 BUILD_DIR is set throghout src_prepare, while in EAPI=8 BUILD_DIR is set after cmake_src_prepare. So run cmake_src_prepare before converting test data. Also, add LD_LIBRARY_PATH when testing Closes: https://github.com/gentoo/gentoo/pull/25313 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/rocSPARSE')
-rw-r--r--sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild b/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild
index b97857618b6c..3a6f6c8063ad 100644
--- a/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild
+++ b/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild
@@ -81,6 +81,8 @@ src_prepare() {
# use python interpreter specifyied by python-any-r1
sed -e "/COMMAND ..\/common\/rocsparse_gentest.py/s,COMMAND ,COMMAND ${EPYTHON} ," -i clients/tests/CMakeLists.txt || die
+ cmake_src_prepare
+
# Test need download data from https://sparse.tamu.edu (or other mirror site), check MD5, unpack and convert them into csr format
# This process is handled default by ${S}/cmake/ClientMatrices.cmake, but should be the responsibility of portage.
if use test; then
@@ -97,8 +99,6 @@ src_prepare() {
eend $?
done
fi
-
- cmake_src_prepare
}
src_configure() {
@@ -125,7 +125,7 @@ src_test() {
addwrite /dev/kfd
addwrite /dev/dri/
cd "${BUILD_DIR}/clients/staging" || die
- ./rocsparse-test || die
+ LD_LIBRARY_PATH="${BUILD_DIR}/library" ./rocsparse-test || die
}
src_install() {