summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2018-10-22 21:02:14 -0600
committerChristoph Junghans <junghans@gentoo.org>2018-10-22 21:02:39 -0600
commit85bbab44ed4573d6a715ed83dbccb703b2d38fc2 (patch)
tree8d5fe1e5e9c0a87a29398febc9deac46c47af2d6 /sci-libs/lmfit
parentnet-wireless/gnuradio: dep cleanup (diff)
downloadgentoo-85bbab44ed4573d6a715ed83dbccb703b2d38fc2.tar.gz
gentoo-85bbab44ed4573d6a715ed83dbccb703b2d38fc2.tar.bz2
gentoo-85bbab44ed4573d6a715ed83dbccb703b2d38fc2.zip
sci-libs/lmfit: version bump
Package-Manager: Portage-2.3.49, Repoman-2.3.11 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-libs/lmfit')
-rw-r--r--sci-libs/lmfit/Manifest1
-rw-r--r--sci-libs/lmfit/files/lmfit-8.0-cmake.patch59
-rw-r--r--sci-libs/lmfit/lmfit-7.0.ebuild2
-rw-r--r--sci-libs/lmfit/lmfit-8.0.ebuild25
4 files changed, 86 insertions, 1 deletions
diff --git a/sci-libs/lmfit/Manifest b/sci-libs/lmfit/Manifest
index a40aaa40c8eb..1514817e48a5 100644
--- a/sci-libs/lmfit/Manifest
+++ b/sci-libs/lmfit/Manifest
@@ -1,3 +1,4 @@
DIST lmfit-5.1.tgz 345077 BLAKE2B df27621745601ffacd2110b28f3e3ea2b06d4c8c3c8fad5dda13bb4d6c2bd9f2a793ff88fab4f6d8c78075278bb26f3f424bd0074095e67ab1780a9d57b72b4b SHA512 1df6ed51d7f2137529793948f6c57ef3658932c9198776925a9f6e1d586352651c93aa053a064db7a201dbb848a7108f284223feff45171d142087539d834b29
DIST lmfit-6.4.tgz 388809 BLAKE2B 48aa619642ac3fd009ec6a8f8b44ee4c800fc3f33e2603b557218cdf37c789159dc3947a648d560b9e2dd7fef08a6644fd25ac61505859dc3b1d151eeea58c27 SHA512 2bd0f24dd4638345b8b1ce6803ddcf45ca3ef888eb285e99f9f158c2e30b0f96016d9d84a112cdbf28f2ba98470e54fe773416179a65264426043c9a5186757d
DIST lmfit-7.0.tgz 37950 BLAKE2B a509110f70e7e863d1172b8d91f7439763f0434702f265751e9955494f4982b4c17f0baaa080af86e5cae7f535555e27b98b45ba6a529061d107e53bdb9fd698 SHA512 78f479786c6e5c417781c6d629f5a517335fac70df049fafdefd511485da4e542c988d69c998f96eaab4306160de4bb09a631ca6ffff74bba70c51428d734fc3
+DIST lmfit-8.0.tgz 42833 BLAKE2B d2ad9f5cd35997c8ce6827148e9ca748f3d14044f515a927442e9e5f57508cdfb729cd7172987a0e94284d7e93f7aafc0cb572137f201994c8d3ad9a9fb64c9b SHA512 3b4e4af6c70269f8752428d416e014d4e69df3f73b25e9ba16dd07afc03598a1dca08050cecba29a3b2651e003e703ba4412716100b1bb55b1830f74f16da676
diff --git a/sci-libs/lmfit/files/lmfit-8.0-cmake.patch b/sci-libs/lmfit/files/lmfit-8.0-cmake.patch
new file mode 100644
index 000000000000..367aa2147ae4
--- /dev/null
+++ b/sci-libs/lmfit/files/lmfit-8.0-cmake.patch
@@ -0,0 +1,59 @@
+from: christoph junghans <junghans@votca.org>
+date: mon, 22 oct 2018 21:00:00 -0600
+subject: [patch] cmake: minor distribution tweaks
+
+- use gnuinstalldirs to allow to configure install dirs
+- allow to disable injecting c flags
+
+signed-off-by: christoph junghans <junghans@votca.org>
+---
+ cmakelists.txt | 7 +++++--
+ lib/cmakelists.txt | 4 ++--
+ man/cmakelists.txt | 2 +-
+ 3 files changed, 8 insertions(+), 5 deletions(-)
+
+diff -Naur lmfit-8.0.orig/CMakeLists.txt lmfit-8.0/CMakeLists.txt
+--- lmfit-8.0.orig/CMakeLists.txt 2018-10-22 20:54:43.452888191 -0600
++++ lmfit-8.0/CMakeLists.txt 2018-10-22 20:56:00.573905982 -0600
+@@ -13,9 +13,12 @@
+ # --- Declare project-wide user flags, and set default values ---
+ option(FITTEST "Build with FitTest" OFF)
+
+-set(destination ${CMAKE_INSTALL_PREFIX})
++include(GNUInstallDirs)
+
+-set(CMAKE_C_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pedantic -Wall -Wno-sign-compare -Wno-unused-result -Wno-parentheses -Wno-unknown-pragmas")
++option(INJECT_C_FLAGS "Inject a bunch of useful c flags" ON)
++if (INJECT_C_FLAGS)
++ set(CMAKE_C_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pedantic -Wall -Wno-sign-compare -Wno-unused-result -Wno-parentheses -Wno-unknown-pragmas")
++endif()
+
+ add_subdirectory(lib)
+ add_subdirectory(demo)
+diff -Naur lmfit-8.0.orig/lib/CMakeLists.txt lmfit-8.0/lib/CMakeLists.txt
+--- lmfit-8.0.orig/lib/CMakeLists.txt 2018-10-22 20:54:43.452888191 -0600
++++ lmfit-8.0/lib/CMakeLists.txt 2018-10-22 20:55:08.073213116 -0600
+@@ -17,9 +17,9 @@
+
+ install(
+ TARGETS ${library_name} LIBRARY
+- DESTINATION ${destination}/lib
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ COMPONENT Libraries)
+ install(
+ FILES ${inc_files}
+- DESTINATION ${destination}/include
++ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ COMPONENT Headers)
+diff -Naur lmfit-8.0.orig/man/CMakeLists.txt lmfit-8.0/man/CMakeLists.txt
+--- lmfit-8.0.orig/man/CMakeLists.txt 2018-10-22 20:54:43.452888191 -0600
++++ lmfit-8.0/man/CMakeLists.txt 2018-10-22 20:55:08.073213116 -0600
+@@ -15,7 +15,7 @@
+ )
+ install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/${pname}.${section}
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/man/man${section}"
++ DESTINATION "${CMAKE_INSTALL_MANDIR}/man${section}"
+ )
+ endfunction()
+
diff --git a/sci-libs/lmfit/lmfit-7.0.ebuild b/sci-libs/lmfit/lmfit-7.0.ebuild
index db342f68909e..e4258a74110a 100644
--- a/sci-libs/lmfit/lmfit-7.0.ebuild
+++ b/sci-libs/lmfit/lmfit-7.0.ebuild
@@ -7,7 +7,7 @@ inherit cmake-utils
DESCRIPTION="library for Levenberg-Marquardt least-squares minimization and curve fitting"
HOMEPAGE="http://apps.jcns.fz-juelich.de/doku/sc/lmfit"
-SRC_URI="http://apps.jcns.fz-juelich.de/src/lmfit/${P}.tgz"
+SRC_URI="http://apps.jcns.fz-juelich.de/src/lmfit/old/${P}.tgz"
LICENSE="BSD-2"
SLOT="0"
diff --git a/sci-libs/lmfit/lmfit-8.0.ebuild b/sci-libs/lmfit/lmfit-8.0.ebuild
new file mode 100644
index 000000000000..db342f68909e
--- /dev/null
+++ b/sci-libs/lmfit/lmfit-8.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="library for Levenberg-Marquardt least-squares minimization and curve fitting"
+HOMEPAGE="http://apps.jcns.fz-juelich.de/doku/sc/lmfit"
+SRC_URI="http://apps.jcns.fz-juelich.de/src/lmfit/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DINJECT_C_FLAGS=OFF
+ )
+
+ cmake-utils_src_configure
+}