summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-29 02:03:53 -0400
committerSam James <sam@gentoo.org>2024-03-29 18:45:14 +0000
commit1d32f41aa6dab138dfec25c8a5433793420d9293 (patch)
treed2402671704a5c73c797818e5c7dfcb7c8aa6fa4 /sci-libs/libticalcs2
parentsci-libs/libticalcs2: update EAPI 6 -> 8 (diff)
downloadgentoo-1d32f41aa6dab138dfec25c8a5433793420d9293.tar.gz
gentoo-1d32f41aa6dab138dfec25c8a5433793420d9293.tar.bz2
gentoo-1d32f41aa6dab138dfec25c8a5433793420d9293.zip
sci-libs/libticalcs2: fix erroneous bashism during building
* QA Notice: Abnormal configure code * * checking for the host compiler... ./configure: 17678: test: xx86_64-pc-linux-gnu: unexpected operator Bug: https://github.com/debrouxl/tilibs/pull/87 Closes: https://bugs.gentoo.org/723452 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/libticalcs2')
-rw-r--r--sci-libs/libticalcs2/files/0001-libticalcs-fix-erroneous-bashism-in-configure-script.patch39
-rw-r--r--sci-libs/libticalcs2/libticalcs2-1.1.9-r1.ebuild5
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/libticalcs2/files/0001-libticalcs-fix-erroneous-bashism-in-configure-script.patch b/sci-libs/libticalcs2/files/0001-libticalcs-fix-erroneous-bashism-in-configure-script.patch
new file mode 100644
index 000000000000..7cf0f173af34
--- /dev/null
+++ b/sci-libs/libticalcs2/files/0001-libticalcs-fix-erroneous-bashism-in-configure-script.patch
@@ -0,0 +1,39 @@
+From e27900a6b30f35b1a586b171603047fec3f39990 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz93@gmail.com>
+Date: Fri, 29 Mar 2024 01:48:47 -0400
+Subject: [PATCH] libticalcs: fix erroneous bashism in configure script
+
+configure scripts are POSIX /bin/sh scripts and cannot have
+bash-specific syntax. The `test xxx == yyy` construct with double equals
+is a bash-specific alias for single equals. It does exactly the same
+thing as single equals -- it provides no additional functionality, no
+behavior changes, it is *exactly* the same but with an additional
+alternate spelling. In exchange for doing nothing, it breaks muscle
+memory when writing POSIX sh scripts and tricks developers into writing
+the wrong thing.
+
+It should never be used under any circumstances. Ideally it would be
+removed altogether from GNU bash.
+
+Bug: https://bugs.gentoo.org/723452
+Signed-off-by: Eli Schwartz <eschwartz93@gmail.com>
+---
+ libticalcs/trunk/configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libticalcs/trunk/configure.ac b/libticalcs/trunk/configure.ac
+index 3ec257ed..42588f9f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -180,7 +180,7 @@ esac
+ AC_ARG_VAR([CXX_FOR_BUILD], [C++ compiler for programs to be run on the build system])
+ AC_ARG_VAR([CXXFLAGS_FOR_BUILD], [C++ compiler flags for CXX_FOR_BUILD])
+ AC_MSG_CHECKING([for the host compiler])
+-if test "x$build" == "x$host" ; then
++if test "x$build" = "x$host" ; then
+ # Not cross-compiling.
+ CXX_FOR_BUILD=$CXX
+ CXXFLAGS_FOR_BUILD=$CXXFLAGS
+--
+2.43.2
+
diff --git a/sci-libs/libticalcs2/libticalcs2-1.1.9-r1.ebuild b/sci-libs/libticalcs2/libticalcs2-1.1.9-r1.ebuild
index d2675ea3c430..88acc8b83976 100644
--- a/sci-libs/libticalcs2/libticalcs2-1.1.9-r1.ebuild
+++ b/sci-libs/libticalcs2/libticalcs2-1.1.9-r1.ebuild
@@ -28,6 +28,11 @@ BDEPEND="
DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
+PATCHES=(
+ # https://github.com/debrouxl/tilibs/pull/87
+ "${FILESDIR}"/0001-libticalcs-fix-erroneous-bashism-in-configure-script.patch
+)
+
src_prepare() {
default
eautoreconf