summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-05-27 15:17:49 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-05-27 15:45:29 +0200
commit5ecf2102bf52c700217f60649e1efa062cd2e832 (patch)
treef7c85c105dca27e7d578c5d40d9050b04e743ef0 /sci-libs/huggingface_hub
parentkde-frameworks/qqc2-desktop-style: Stabilize 5.106.0 amd64, #906676 (diff)
downloadgentoo-5ecf2102bf52c700217f60649e1efa062cd2e832.tar.gz
gentoo-5ecf2102bf52c700217f60649e1efa062cd2e832.tar.bz2
gentoo-5ecf2102bf52c700217f60649e1efa062cd2e832.zip
sci-libs/huggingface_hub: add 0.14.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/huggingface_hub')
-rw-r--r--sci-libs/huggingface_hub/Manifest1
-rw-r--r--sci-libs/huggingface_hub/huggingface_hub-0.14.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/huggingface_hub/Manifest b/sci-libs/huggingface_hub/Manifest
index 864a1294e192..1caa5dc407e5 100644
--- a/sci-libs/huggingface_hub/Manifest
+++ b/sci-libs/huggingface_hub/Manifest
@@ -1 +1,2 @@
DIST huggingface_hub-0.13.4.gh.tar.gz 325227 BLAKE2B 56ad70072ddd7f9878de4db45fffeb200032d71ba36fa2dc0e81d50a079a5ffa9ad80b3a71773a5fe466ac4522db7061fc7974149092d212278b8159d30e212b SHA512 6c07c1dc1a0c327ca463b7f366c265dfc7e55ed69592df5ad10f6d77956ac1dfe3e1f827a2df200f943da2f34a96ba4de1c395944b542e3d7142d925f60ad274
+DIST huggingface_hub-0.14.1.gh.tar.gz 359222 BLAKE2B 379cc49230f2e8f5f57d0dac5cfab60f9d0a7d04bab36af8ba0a77846fdf6eea412f9d473bd2f554a912a862747156fe29d36913691b6df8c3cf769389d86b3f SHA512 8d1e9c3e77a8ddb4a6b1827751fad95baad7504a1ad2cdf443f1cf64cff10e1cea9148f2076e0fd462c7f1ce860230e919059e61807260368727a6bd5e9efeb3
diff --git a/sci-libs/huggingface_hub/huggingface_hub-0.14.1.ebuild b/sci-libs/huggingface_hub/huggingface_hub-0.14.1.ebuild
new file mode 100644
index 000000000000..7c519b339f79
--- /dev/null
+++ b/sci-libs/huggingface_hub/huggingface_hub-0.14.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="a client library to interact with the Hugging Face Hub"
+HOMEPAGE="
+ https://pypi.org/project/huggingface_hub/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" #Several modules not yet packaged
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest