summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2023-07-30 11:10:20 +0800
committerBenda Xu <heroxbd@gentoo.org>2023-07-30 12:35:34 +0800
commit9edc7b68ee8a0e1f2e6e18f4675e97e5f257dc7f (patch)
tree76ca56435587acc36c18ebd67b1d4344b9e7076e /sci-libs/hipRAND
parentsci-libs/rocFFT: normalize the header directory. (diff)
downloadgentoo-9edc7b68ee8a0e1f2e6e18f4675e97e5f257dc7f.tar.gz
gentoo-9edc7b68ee8a0e1f2e6e18f4675e97e5f257dc7f.tar.bz2
gentoo-9edc7b68ee8a0e1f2e6e18f4675e97e5f257dc7f.zip
sci-libs/hipRAND: new package, add 5.6.0
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/hipRAND')
-rw-r--r--sci-libs/hipRAND/Manifest1
-rw-r--r--sci-libs/hipRAND/hipRAND-5.6.0.ebuild36
-rw-r--r--sci-libs/hipRAND/metadata.xml15
3 files changed, 52 insertions, 0 deletions
diff --git a/sci-libs/hipRAND/Manifest b/sci-libs/hipRAND/Manifest
new file mode 100644
index 000000000000..bdb2c56b0452
--- /dev/null
+++ b/sci-libs/hipRAND/Manifest
@@ -0,0 +1 @@
+DIST hipFFT-rocm-5.6.0.tar.gz 477597 BLAKE2B fdc88ac7076ab6b31ba794f9274881323fba32295bab5b90e38d8c8f336e0255b7d20dcba6e334b7bacd8b67eaac8a3ac6e11e3d490e7c95a973d16c9598922f SHA512 47d0cca92b458f8ef682b3c15fe4ccc5201370b1458e541080dc2150e98256962b78806c20b26d789b232d420eb305639fa50180e379ba123851d35d24d40cb2
diff --git a/sci-libs/hipRAND/hipRAND-5.6.0.ebuild b/sci-libs/hipRAND/hipRAND-5.6.0.ebuild
new file mode 100644
index 000000000000..d0bd5ace71e4
--- /dev/null
+++ b/sci-libs/hipRAND/hipRAND-5.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ROCM_VERSION=${PV}
+
+inherit cmake rocm
+
+DESCRIPTION="CU / ROCM agnostic hip RAND implementation"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipRAND"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/hipRAND/archive/refs/tags/rocm-${PV}.tar.gz -> hipFFT-rocm-${PV}.tar.gz"
+REQUIRED_USE="${ROCM_REQUIRED_USE}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+
+RESTRICT="test"
+
+RDEPEND="dev-util/hip
+ sci-libs/rocRAND:${SLOT}[${ROCM_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/hipRAND-rocm-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DAMDGPU_TARGETS="$(get_amdgpu_flags)"
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ -DROCM_SYMLINK_LIBS=OFF
+ )
+
+ CXX=hipcc cmake_src_configure
+}
diff --git a/sci-libs/hipRAND/metadata.xml b/sci-libs/hipRAND/metadata.xml
new file mode 100644
index 000000000000..27c8916b67d4
--- /dev/null
+++ b/sci-libs/hipRAND/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>xgreenlandforwyy@gmail.com</email>
+ <name>Yiyang Wu</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ROCmSoftwarePlatform/hipRAND</remote-id>
+ </upstream>
+</pkgmetadata>