summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/dlib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/dlib')
-rw-r--r--sci-libs/dlib/Manifest2
-rw-r--r--sci-libs/dlib/dlib-18.15.ebuild45
-rw-r--r--sci-libs/dlib/dlib-18.7.ebuild45
-rw-r--r--sci-libs/dlib/files/dlib-17.48-makefile-test.patch35
-rw-r--r--sci-libs/dlib/metadata.xml14
5 files changed, 141 insertions, 0 deletions
diff --git a/sci-libs/dlib/Manifest b/sci-libs/dlib/Manifest
new file mode 100644
index 000000000000..a3a80ea6ce46
--- /dev/null
+++ b/sci-libs/dlib/Manifest
@@ -0,0 +1,2 @@
+DIST dlib-18.15.tar.bz2 7088379 SHA256 e2b790222d625c863d43b3b7dec86a826b504fc10b4b69b242f59a82e9dda16c SHA512 16f42fcdc63214b72328204fca2f7e3d36e18a67fd0f4b97acd9fa5046d7bf41f56ab4209a7a92c54896746b72f6f925ae07ca57ea89982c7e26c0a4ee4b693c WHIRLPOOL a15e181de3e43b800932ce338312ed875788c561bb7ed0ad689882b892f72da891b2a8547763472101e835b652322ab6ab301c6cbf117e2442156320f8603716
+DIST dlib-18.7.tar.bz2 5676950 SHA256 e3d801905288683eee245ff205081343eb79d31d5bb50e42f0293fe5b4a3697e SHA512 20f746a430bd3327f6329d9b198da67d66880f63185b5cd000bcd61a203fad6d775b77c923c92186c122ecd4d4e84f5463e4f81da86b4158d9cc24697cb54365 WHIRLPOOL f7c11fd295f791ce9e2b40c5121a20b3d14ced4d574dc1401a3eb4b2e646fae0f5b01b5a4b4ed6532dea9bcf1c0657147ae32f1e4e9c367fe357ec28287cbec3
diff --git a/sci-libs/dlib/dlib-18.15.ebuild b/sci-libs/dlib/dlib-18.15.ebuild
new file mode 100644
index 000000000000..784e7eb8cf85
--- /dev/null
+++ b/sci-libs/dlib/dlib-18.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Numerical and networking C++ library"
+HOMEPAGE="http://dlib.net/"
+SRC_URI="mirror://sourceforge/dclib/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="blas doc examples jpeg lapack png test X"
+
+RDEPEND="
+ blas? ( virtual/blas )
+ jpeg? ( virtual/jpeg:0= )
+ lapack? ( virtual/lapack )
+ png? ( media-libs/libpng:0= )
+ X? ( x11-libs/libX11 )"
+DEPEND="test? ( ${RDEPEND} )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-17.48-makefile-test.patch
+}
+
+src_test() {
+ cd dlib/test || die
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}"
+ ./dtest --runall || die
+}
+
+src_install() {
+ dodoc dlib/README.txt
+ rm -r dlib/{README,LICENSE}.txt dlib/test || die
+ doheader -r dlib
+ use doc && dohtml -r docs/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/dlib/dlib-18.7.ebuild b/sci-libs/dlib/dlib-18.7.ebuild
new file mode 100644
index 000000000000..d2b754df369b
--- /dev/null
+++ b/sci-libs/dlib/dlib-18.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Numerical and networking C++ library"
+HOMEPAGE="http://dlib.net/"
+SRC_URI="mirror://sourceforge/dclib/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="blas doc examples jpeg lapack png test X"
+
+RDEPEND="
+ blas? ( virtual/blas )
+ jpeg? ( virtual/jpeg:0= )
+ lapack? ( virtual/lapack )
+ png? ( media-libs/libpng:0= )
+ X? ( x11-libs/libX11 )"
+DEPEND="test? ( ${RDEPEND} )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-17.48-makefile-test.patch
+}
+
+src_test() {
+ cd dlib/test || die
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}"
+ ./test --runall || die
+}
+
+src_install() {
+ dodoc dlib/README.txt
+ rm -r dlib/{README,LICENSE}.txt dlib/test || die
+ doheader -r dlib
+ use doc && dohtml -r docs/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/dlib/files/dlib-17.48-makefile-test.patch b/sci-libs/dlib/files/dlib-17.48-makefile-test.patch
new file mode 100644
index 000000000000..81aed4431954
--- /dev/null
+++ b/sci-libs/dlib/files/dlib-17.48-makefile-test.patch
@@ -0,0 +1,35 @@
+--- dlib/test/makefile.orig 2012-12-10 23:56:00.000000000 +0000
++++ dlib/test/makefile 2012-12-10 23:59:07.000000000 +0000
+@@ -5,14 +5,15 @@
+ TARGET = test
+
+ # these are the compile time flags passed to gcc
+-CFLAGS = -ggdb -DDEBUG -DDLIB_NO_GUI_SUPPORT -I ../.. -Wall
++CPPFLAGS := -DDEBUG -DDLIB_NO_GUI_SUPPORT -I../..
++CXXFLAGS := -ggdb -Wall
+
+ # These are the link time flags passed to gcc
+ LFLAGS = -lpthread -lnsl
+
+ # The name of the compiler. If you only have one version of
+ # gcc installed then you probably want to change this to just g++
+-CC = nice g++
++CXX := nice g++
+
+ ####################################################
+ ####################################################
+@@ -146,13 +147,9 @@
+
+ $(TARGET): $(OBJ)
+ @echo Linking $@
+- @$(CC) $(OBJ) $(LFLAGS) -o $@
++ @$(CXX) $(LDFLAGS) $(OBJ) $(LFLAGS) -o $@
+ @echo Build Complete
+
+-.cpp.o: $<
+- @echo Compiling $<
+- @$(CC) -c $(CFLAGS) $< -o $@
+-
+ clean:
+ @rm -f $(OBJ) $(TARGET)
+ @echo All object files and binaries removed
diff --git a/sci-libs/dlib/metadata.xml b/sci-libs/dlib/metadata.xml
new file mode 100644
index 000000000000..80d9f9e16c0f
--- /dev/null
+++ b/sci-libs/dlib/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ dlib is a C++ library for developing portable applications dealing with
+ networking, threads, graphical interfaces, data structures, linear
+ algebra, machine learning, XML and text parsing, numerical
+ optimization, Bayesian nets, and numerous other tasks.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">dclib</remote-id>
+ </upstream>
+</pkgmetadata>