summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-02-26 14:13:36 -0500
committerSam James <sam@gentoo.org>2021-02-27 03:06:42 +0000
commit39897f1a304088d98599fd6675b0580ccb698ac6 (patch)
tree65ed857eb842193bade3fb9d83038ac811cfaca2 /sci-libs/coinor-cppad/files
parentsci-libs/coinor-cppad: add github remote-id (diff)
downloadgentoo-39897f1a304088d98599fd6675b0580ccb698ac6.tar.gz
gentoo-39897f1a304088d98599fd6675b0580ccb698ac6.tar.bz2
gentoo-39897f1a304088d98599fd6675b0580ccb698ac6.zip
sci-libs/coinor-cppad: bump to 20210000.5, ported to EAPI 7 + cmake
Most old issues should be resolved or need re-test as this is completely different now. wrt bug #741428, tests currently pass using clang++ and default USE. Closes: https://bugs.gentoo.org/603226 Closes: https://bugs.gentoo.org/725470 Closes: https://bugs.gentoo.org/741428 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/coinor-cppad/files')
-rw-r--r--sci-libs/coinor-cppad/files/coinor-cppad-20210000.5-pkgconfig.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/coinor-cppad/files/coinor-cppad-20210000.5-pkgconfig.patch b/sci-libs/coinor-cppad/files/coinor-cppad-20210000.5-pkgconfig.patch
new file mode 100644
index 000000000000..0483eea52ec4
--- /dev/null
+++ b/sci-libs/coinor-cppad/files/coinor-cppad-20210000.5-pkgconfig.patch
@@ -0,0 +1,26 @@
+Fix pkg-config file generation, backported from upstream commit:
+https://github.com/coin-or/CppAD/commit/6d10b8d
+with an additional fix to not have -l-lcppad_lib
+--- a/pkgconfig/CMakeLists.txt
++++ b/pkgconfig/CMakeLists.txt
+@@ -124,3 +124,3 @@
+ # cppad_includedir
+-LIST(GET cmake_install_libdirs 0 cppad_includedir)
++LIST(GET cmake_install_includedirs 0 cppad_includedir)
+ #
+@@ -161,2 +161,3 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/cppad.pc
++ @ONLY
+ )
+--- a/pkgconfig/cppad.pc.in
++++ b/pkgconfig/cppad.pc.in
+@@ -17,3 +17,3 @@
+ prefix=@cppad_prefix@
+-exec_prefix=$(prefix)
++exec_prefix=${prefix}
+ includedir=${prefix}/@cppad_includedir@
+@@ -30,3 +30,3 @@
+ Cflags: -I${includedir}
+-Libs: -L{libdir} -l@cppad_lib_list@
++Libs: -L${libdir} @cppad_lib_list@
+ Requires: