summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-clp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-clp')
-rw-r--r--sci-libs/coinor-clp/Manifest1
-rw-r--r--sci-libs/coinor-clp/coinor-clp-1.15.6-r1.ebuild116
-rw-r--r--sci-libs/coinor-clp/files/coinor-clp-1.15.6-mpi-header.patch12
-rw-r--r--sci-libs/coinor-clp/files/coinor-clp-1.15.6-overflow.patch11
-rw-r--r--sci-libs/coinor-clp/metadata.xml20
5 files changed, 160 insertions, 0 deletions
diff --git a/sci-libs/coinor-clp/Manifest b/sci-libs/coinor-clp/Manifest
new file mode 100644
index 000000000000..841066903d89
--- /dev/null
+++ b/sci-libs/coinor-clp/Manifest
@@ -0,0 +1 @@
+DIST Clp-1.15.6.tgz 5644504 SHA256 4f1ff52f7b471d795d395f561bb10cc2d5a11ecd151bc5329f6f60d448b8385f SHA512 a0da0cc5dcdd409c67cb67dd0f126a3d96bf59851543e7e08adbdbf01012a25905b58ded66aac50b06462ee3a147bed912740c00681417f8c228992a917748db WHIRLPOOL 0712972a59790daac6ddbae1b53458361e4f324f84bb5706b4d59e46eb538a69b22b1e236b550fdaa20201fd5adcc33a8f69f296a9ce022a15ea93b73897833c
diff --git a/sci-libs/coinor-clp/coinor-clp-1.15.6-r1.ebuild b/sci-libs/coinor-clp/coinor-clp-1.15.6-r1.ebuild
new file mode 100644
index 000000000000..80aa38ee32b2
--- /dev/null
+++ b/sci-libs/coinor-clp/coinor-clp-1.15.6-r1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils eutils multilib toolchain-funcs
+
+MYPN=Clp
+
+DESCRIPTION="COIN-OR Linear Programming solver"
+HOMEPAGE="https://projects.coin-or.org/Clp/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples glpk metis mumps sparse static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:=
+ glpk? ( sci-mathematics/glpk:= sci-libs/amd )
+ metis? ( || ( sci-libs/metis sci-libs/parmetis ) )
+ mumps? ( sci-libs/mumps )
+ sparse? ( sci-libs/cholmod )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.15.6-mpi-header.patch
+ "${FILESDIR}"/${PN}-1.15.6-overflow.patch
+)
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ if has_version sci-libs/mumps[-mpi]; then
+ ln -s "${EPREFIX}"/usr/include/mpiseq/mpi.h src/mpi.h
+ elif has_version sci-libs/mumps[mpi]; then
+ export CXX=mpicxx
+ fi
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-aboca
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
+ )
+ if use glpk; then
+ myeconfargs+=(
+ --with-amd-incdir="${EPREFIX}"/usr/include
+ --with-amd-lib=-lamd
+ --with-glpk-incdir="${EPREFIX}"/usr/include
+ --with-glpk-lib=-lglpk )
+ else
+ myeconfargs+=( --without-glpk )
+ fi
+ if use sparse; then
+ myeconfargs+=(
+ --with-amd-incdir="${EPREFIX}"/usr/include
+ --with-amd-lib=-lamd
+ --with-cholmod-incdir="${EPREFIX}"/usr/include
+ --with-cholmod-lib=-lcholmod )
+ else
+ myeconfargs+=( --without-amd --without-cholmod )
+ fi
+ if use metis; then
+ myeconfargs+=(
+ --with-metis-incdir="$($(tc-getPKG_CONFIG) --cflags metis | sed s/-I//)"
+ --with-metis-lib="$($(tc-getPKG_CONFIG) --libs metis)" )
+ else
+ myeconfargs+=( --without-metis )
+ fi
+ if use mumps; then
+ myeconfargs+=(
+ --with-mumps-incdir="${EPREFIX}"/usr/include
+ --with-mumps-lib="-lmumps_common -ldmumps -lzmumps -lsmumps -lcmumps" )
+ else
+ myeconfargs+=( --without-mumps )
+ fi
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ # hack for parallel build, to overcome not patching Makefile.am above
+ #autotools-utils_src_compile -C src libClp.la
+ autotools-utils_src_compile all $(usex doc doxydoc "")
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
+ # hack for parallel install, to overcome not patching Makefile.am above
+ #autotools-utils_src_install -C src install-am
+ autotools-utils_src_install
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-clp/files/coinor-clp-1.15.6-mpi-header.patch b/sci-libs/coinor-clp/files/coinor-clp-1.15.6-mpi-header.patch
new file mode 100644
index 000000000000..7ad03e8c76c4
--- /dev/null
+++ b/sci-libs/coinor-clp/files/coinor-clp-1.15.6-mpi-header.patch
@@ -0,0 +1,12 @@
+--- src/ClpCholeskyMumps.cpp.orig 2013-06-19 09:58:02.834485943 -0700
++++ src/ClpCholeskyMumps.cpp 2013-06-19 09:57:39.013355095 -0700
+@@ -14,8 +14,8 @@
+ #define USE_COMM_WORLD -987654
+ extern "C" {
+ #include "dmumps_c.h"
+-#include "mpi.h"
+ }
++#include "mpi.h"
+
+ #include "ClpCholeskyMumps.hpp"
+ #include "ClpMessage.hpp"
diff --git a/sci-libs/coinor-clp/files/coinor-clp-1.15.6-overflow.patch b/sci-libs/coinor-clp/files/coinor-clp-1.15.6-overflow.patch
new file mode 100644
index 000000000000..cded22bf384c
--- /dev/null
+++ b/sci-libs/coinor-clp/files/coinor-clp-1.15.6-overflow.patch
@@ -0,0 +1,11 @@
+--- src/ClpPdco.cpp.orig 2014-01-14 11:44:22.717643715 -0800
++++ src/ClpPdco.cpp 2014-01-14 11:43:12.543202133 -0800
+@@ -316,7 +316,7 @@
+ //bool useChol = (LSmethod == 1);
+ //bool useQR = (LSmethod == 2);
+ bool direct = (LSmethod <= 2 && ifexplicit);
+- char solver[6];
++ char solver[7];
+ strcpy(solver, " LSQR");
+
+
diff --git a/sci-libs/coinor-clp/metadata.xml b/sci-libs/coinor-clp/metadata.xml
new file mode 100644
index 000000000000..8c7fb9886919
--- /dev/null
+++ b/sci-libs/coinor-clp/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Clp (Coin-or linear programming) is an open-source linear
+ programming solver written in C++. It is primarily meant to be used
+ as a callable library, but a basic, stand-alone executable version
+ is also available. It is designed to find solutions of constrained
+ linear mathematical optimization problems.
+</longdescription>
+<use>
+ <flag name='glpk'>Enable GNU Linear Programming Kit
+ <pkg>sci-mathematics/glpk</pkg> support</flag>
+ <flag name='metis'>Enable partitioning with
+ <pkg>sci-libs/metis</pkg></flag>
+ <flag name='mumps'>Enable <pkg>sci-libs/mumps</pkg> support</flag>
+ <flag name='sparse'>Enable support for sparse matrix with <pkg>sci-libs/cholmod</pkg></flag>
+</use>
+</pkgmetadata>