summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-02-25 23:28:39 -0500
committerSam James <sam@gentoo.org>2021-02-27 03:06:20 +0000
commit059ec74e6c970895beeb8d0fe8380f094da56756 (patch)
tree742b04adc4b7f0feebaa1fc67510e56c74138c7c /sci-libs/coinor-bcps
parentsci-libs/coinor-bcps: add github remote-id (diff)
downloadgentoo-059ec74e6c970895beeb8d0fe8380f094da56756.tar.gz
gentoo-059ec74e6c970895beeb8d0fe8380f094da56756.tar.bz2
gentoo-059ec74e6c970895beeb8d0fe8380f094da56756.zip
sci-libs/coinor-bcps: bump to 0.94.5, ported to EAPI 7
Has reworked old workarounds and reviewed deps, notably the missing coinor-cgl test dep (bug #725442). USE=examples removed, now installed unconditionally (small files). USE=doc now installs html docs. USE=static-libs removed. Closes: https://bugs.gentoo.org/725442 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/coinor-bcps')
-rw-r--r--sci-libs/coinor-bcps/Manifest1
-rw-r--r--sci-libs/coinor-bcps/coinor-bcps-0.94.5.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/coinor-bcps/Manifest b/sci-libs/coinor-bcps/Manifest
index d64d7b22649b..e6e5b907b130 100644
--- a/sci-libs/coinor-bcps/Manifest
+++ b/sci-libs/coinor-bcps/Manifest
@@ -1 +1,2 @@
DIST Bcps-0.93.10.tgz 6270009 BLAKE2B 45372ae18a3f4a7e75d4f71fa6ba411317fc282415390f6e11181543bdac254c5820e8544ffd6c43e8dcb507a8dc5329a42b9cbfc23256a395cc73bc3a8d631b SHA512 4e9348dc1bf75fd9afb74078b55ae0f9a84a99236886552256d7548013c8af4695a4fcc2787ffb0228eba2a870b1cb78c068234048c8650f7d504e1e8d17c549
+DIST coinor-bcps-0.94.5.tar.gz 701818 BLAKE2B 3f01e0fac2e892a3cf59e7dba78c58a23f465f48b0a44be933acfb7d59e84012bed3e05f2f8d1b3c578ad24f4f9c23af9d5e7d54e47b45b0500d389dcfbcf47f SHA512 b53a2ad62a832d4beb0ce2b5c7fd0e81eeb01b9039c0b78ce849adb94b44ad2300aad0f6357ecbcf41f5a5bb427508bde931667dfe40eaa83de50e3d696e3211
diff --git a/sci-libs/coinor-bcps/coinor-bcps-0.94.5.ebuild b/sci-libs/coinor-bcps/coinor-bcps-0.94.5.ebuild
new file mode 100644
index 000000000000..7776577f7aa2
--- /dev/null
+++ b/sci-libs/coinor-bcps/coinor-bcps-0.94.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="COIN-OR BiCePS data handling library"
+HOMEPAGE="https://projects.coin-or.org/CHiPPS/"
+SRC_URI="https://github.com/coin-or/CHiPPS-BiCePS/archive/releases/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/CHiPPS-BiCePS-releases-${PV}/Bcps"
+
+LICENSE="EPL-1.0"
+SLOT="0" # formerly 0/1, upstream went from so.1 to so.0
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+# Note: 0.99.x branch needs to-be-released >=coinor-alps-1.5.8
+RDEPEND="
+ sci-libs/coinor-alps:=
+ sci-libs/coinor-utils:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? (
+ sci-libs/coinor-cgl
+ sci-libs/coinor-sample
+ )"
+
+src_prepare() {
+ default
+ # Prevent unneeded call to pkg-config that needs ${ED}'s in path.
+ sed -i '/--libs.*addlibs.txt/d' Makefile.in || die
+}
+
+src_configure() {
+ econf $(use_with doc dot)
+}
+
+src_compile() {
+ emake all $(usex doc doxydoc '')
+}
+
+src_test() {
+ # Needed given "make check" is a noop and it skips the working one.
+ emake test
+}
+
+src_install() {
+ default
+ dodoc -r examples
+ use doc && dodoc -r doxydoc/html
+
+ # Duplicate or irrelevant files.
+ rm -r "${ED}"/usr/share/coin/doc || die
+ find "${ED}" -name '*.la' -delete || die
+}