summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-02-27 08:13:55 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-02-27 08:23:15 +0100
commit04f1c73d1190c41edc24667ebd0c2505c62a6706 (patch)
treef935624d2f57073326aaed43257ece162b7654d3 /sci-libs/caffe2
parentdev-java/reflections: depend on javax-servlet-api instead on tomcat-servlet-api (diff)
downloadgentoo-04f1c73d1190c41edc24667ebd0c2505c62a6706.tar.gz
gentoo-04f1c73d1190c41edc24667ebd0c2505c62a6706.tar.bz2
gentoo-04f1c73d1190c41edc24667ebd0c2505c62a6706.zip
sci-libs/caffe2: find the right GCC for CUDA
Closes: https://bugs.gentoo.org/888039 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/caffe2')
-rw-r--r--sci-libs/caffe2/caffe2-1.13.1-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sci-libs/caffe2/caffe2-1.13.1-r1.ebuild b/sci-libs/caffe2/caffe2-1.13.1-r1.ebuild
index 352a593d3559..4e0dfcb9b980 100644
--- a/sci-libs/caffe2/caffe2-1.13.1-r1.ebuild
+++ b/sci-libs/caffe2/caffe2-1.13.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit python-single-r1 cmake flag-o-matic
+inherit python-single-r1 cmake cuda flag-o-matic
MYPN=pytorch
MYP=${MYPN}-${PV}
@@ -148,7 +148,13 @@ src_configure() {
-DLIBSHM_INSTALL_LIB_SUBDIR="${EPREFIX}"/usr/$(get_libdir)
)
- use cuda && addpredict "/dev/nvidiactl" # bug 867706
+ if use cuda; then
+ addpredict "/dev/nvidiactl" # bug 867706
+
+ mycmakeargs+=(
+ -DCMAKE_CUDA_FLAGS="$(cuda_gccdir -f | tr -d \")"
+ )
+ fi
cmake_src_configure
}