summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-09-29 09:52:19 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-09-29 09:58:30 -0400
commite70d02d40d0998378db8dbf111a0ddfcbc5a5b76 (patch)
treeab084ebe3a5943ba19be51ceae56a32d7ba3edd6 /sci-libs/brial
parentcmake.eclass: Reformat the cmake code we write to lowercase calls (diff)
downloadgentoo-e70d02d40d0998378db8dbf111a0ddfcbc5a5b76.tar.gz
gentoo-e70d02d40d0998378db8dbf111a0ddfcbc5a5b76.tar.bz2
gentoo-e70d02d40d0998378db8dbf111a0ddfcbc5a5b76.zip
sci-libs/brial: new version 1.2.9.
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/brial')
-rw-r--r--sci-libs/brial/Manifest1
-rw-r--r--sci-libs/brial/brial-1.2.9.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/brial/Manifest b/sci-libs/brial/Manifest
index f3d47c7a9b98..d2b36e43608f 100644
--- a/sci-libs/brial/Manifest
+++ b/sci-libs/brial/Manifest
@@ -1 +1,2 @@
DIST brial-1.2.8.tar.bz2 1228732 BLAKE2B f9bdfc9416381f3436c555861806a7ea4680e706729b6de9c2b06ea2908090b87b745fe5ce2d94ba9d5832a78067e4848f8ef113b7d8dc22557b6d95b7dad707 SHA512 a94acba140d976dd070b5214c537fb3dba89fc2309addc566b8f0a031328f2d4c2bb3c38c2cb5565c7ff2ca0c5f7f56ca120899d15c768887d3b61a18b3e05be
+DIST brial-1.2.9.tar.bz2 1230234 BLAKE2B c083931793976deee592e91efcc8ae2fa501c5a2b5cb04fd8449e225c84d5bbe9255480641694e8aac4f299c6ab1800bf21713278d0f8def4a1f335643751cdd SHA512 f5dfcab6b324d1151e06ce3af0f085ebf692d26cd4b38203c835a35a6f0f25d09f6c4a6ebf44b12c3a9c9125dddb2e94a43f1d04b59d07995392b50ada54d410
diff --git a/sci-libs/brial/brial-1.2.9.ebuild b/sci-libs/brial/brial-1.2.9.ebuild
new file mode 100644
index 000000000000..e1831c017fc6
--- /dev/null
+++ b/sci-libs/brial/brial-1.2.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A C++ library for polynomials over boolean rings"
+HOMEPAGE="https://github.com/BRiAl/BRiAl"
+SRC_URI="https://github.com/BRiAl/BRiAl/releases/download/${PV}/${P}.tar.bz2"
+
+# The top-level license is GPL2+, but cudd/LICENSE is BSD.
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="png static-libs"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/boost
+ sci-libs/m4ri[png=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup(){
+ tc-export PKG_CONFIG
+}
+
+src_configure(){
+ # with-boost-libdir added to deal with some rather quirky setups
+ # see https://github.com/cschwan/sage-on-gentoo/issues/551
+ econf \
+ --with-boost="${EPREFIX}"/usr \
+ --with-boost-libdir="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}