summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/viking
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/viking')
-rw-r--r--sci-geosciences/viking/Manifest2
-rw-r--r--sci-geosciences/viking/files/1.3-autoreconf.patch12
-rw-r--r--sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch53
-rw-r--r--sci-geosciences/viking/metadata.xml25
-rw-r--r--sci-geosciences/viking/viking-1.6-r2.ebuild75
5 files changed, 167 insertions, 0 deletions
diff --git a/sci-geosciences/viking/Manifest b/sci-geosciences/viking/Manifest
new file mode 100644
index 000000000000..cc47ba2b7a2f
--- /dev/null
+++ b/sci-geosciences/viking/Manifest
@@ -0,0 +1,2 @@
+DIST viking-1.6.tar.bz2 3060389 SHA256 21f1bd372c571b8d021e4509a69ec6448efefec623355a9db26cd81898b5920a SHA512 7716f5720bcd410fa4a2a89ff87548c82a83132003733e6a3f516c51df99ffed4fa3b19631cec9ccedd27b222188a0f092c28ab9af1cefd8d8137b5801eff042 WHIRLPOOL 2f50b35e1362e993553f57682b25a7349c92d140c70f85ab3f22bc5a176769d15728ab643a35fd75fc63c836235f734c7e6388c74cfb5e41dfd868dcb9a7ec2d
+DIST viking.pdf 383200 SHA256 b45d2c35c36484f9e3550c2b161fc7c60609e0f1f6f163f73ff70886f5532138 SHA512 481c88afd43783475366d41cd46a7fa5fdbcd20fec27b3ce286fb8abe1e9efbb4164def0d19fca2380fa95b5b97e9472f25ff5e10f8d95261e85b7c4a52d29ee WHIRLPOOL b674549c160429de8757f337699d596be2573158a64f6d873b59769eddc1afa8519e4ab0ac8f13f6a36b57da11f85c5f1fa061eb06ba61cdc026bbc4702ab33e
diff --git a/sci-geosciences/viking/files/1.3-autoreconf.patch b/sci-geosciences/viking/files/1.3-autoreconf.patch
new file mode 100644
index 000000000000..c8ddd6f6873a
--- /dev/null
+++ b/sci-geosciences/viking/files/1.3-autoreconf.patch
@@ -0,0 +1,12 @@
+--- configure.ac.orig 2012-05-31 09:40:33.543090992 +0200
++++ configure.ac 2012-05-31 09:40:44.372640811 +0200
+@@ -350,9 +350,6 @@
+ help/Makefile
+ doc/Makefile
+ doc/examples/Makefile])
+-if test x$enable_gtk_doc = xyes; then
+-AC_CONFIG_FILES([doc/reference/Makefile])
+-fi
+ AC_OUTPUT([
+ viking.spec
+ ])
diff --git a/sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch b/sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch
new file mode 100644
index 000000000000..d559746ff81c
--- /dev/null
+++ b/sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch
@@ -0,0 +1,53 @@
+commit 25043ca24a55468dc9eeaa7335a24d132c51b07d
+Author: Rob Norris <rw_norris@hotmail.com>
+Date: Mon Mar 9 23:25:15 2015 +0000
+
+ SF Bugs#117: Confirm capability with GPSD_API_MAJOR_VERSION=6 (gpsd 3.12 / libgps.so.22)
+
+diff --git a/src/vikgpslayer.c b/src/vikgpslayer.c
+index daf6d42..ca4be29 100644
+--- a/src/vikgpslayer.c
++++ b/src/vikgpslayer.c
+@@ -1673,7 +1673,7 @@ static gboolean gpsd_data_available(GIOChannel *source, GIOCondition condition,
+ if (condition == G_IO_IN) {
+ #if GPSD_API_MAJOR_VERSION == 3 || GPSD_API_MAJOR_VERSION == 4
+ if (!gps_poll(&vgl->vgpsd->gpsd)) {
+-#elif GPSD_API_MAJOR_VERSION == 5
++#elif GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ if (gps_read(&vgl->vgpsd->gpsd) > -1) {
+ // Reuse old function to perform operations on the new GPS data
+ gpsd_raw_hook(vgl->vgpsd, NULL);
+@@ -1718,7 +1718,7 @@ static gboolean rt_gpsd_try_connect(gpointer *data)
+ vgl->vgpsd = g_malloc(sizeof(VglGpsd));
+
+ if (gps_open_r(vgl->gpsd_host, vgl->gpsd_port, /*(struct gps_data_t *)*/vgl->vgpsd) != 0) {
+-#elif GPSD_API_MAJOR_VERSION == 5
++#elif GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ vgl->vgpsd = g_malloc(sizeof(VglGpsd));
+ if (gps_open(vgl->gpsd_host, vgl->gpsd_port, &vgl->vgpsd->gpsd) != 0) {
+ #else
+@@ -1757,7 +1757,7 @@ static gboolean rt_gpsd_try_connect(gpointer *data)
+ #if GPSD_API_MAJOR_VERSION == 3
+ gps_query(&vgl->vgpsd->gpsd, "w+x");
+ #endif
+-#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5
++#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ gps_stream(&vgl->vgpsd->gpsd, WATCH_ENABLE, NULL);
+ #endif
+
+@@ -1813,13 +1813,13 @@ static void rt_gpsd_disconnect(VikGpsLayer *vgl)
+ vgl->realtime_io_channel = NULL;
+ }
+ if (vgl->vgpsd) {
+-#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5
++#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ gps_stream(&vgl->vgpsd->gpsd, WATCH_DISABLE, NULL);
+ #endif
+ gps_close(&vgl->vgpsd->gpsd);
+ #if GPSD_API_MAJOR_VERSION == 3
+ free(vgl->vgpsd);
+-#elif GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5
++#elif GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ g_free(vgl->vgpsd);
+ #endif
+ vgl->vgpsd = NULL;
diff --git a/sci-geosciences/viking/metadata.xml b/sci-geosciences/viking/metadata.xml
new file mode 100644
index 000000000000..b1a37b4886e5
--- /dev/null
+++ b/sci-geosciences/viking/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-geosciences</herd>
+ <maintainer>
+ <email>graaff@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="libexif">
+ Use <pkg>media-libs/libexif</pkg> for EXIF support
+ </flag>
+ <flag name="magic">
+ Use libmagic to determine mimetypes
+ </flag>
+ <flag name="mapnik">
+ Enable a layer based on <pkg>sci-geosciences/mapnik</pkg>
+ </flag>
+ <flag name="sqlite">
+ Enable MBTiles support based on <pkg>dev-db/sqlite</pkg>
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">viking</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/viking/viking-1.6-r2.ebuild b/sci-geosciences/viking/viking-1.6-r2.ebuild
new file mode 100644
index 000000000000..1a7baa725959
--- /dev/null
+++ b/sci-geosciences/viking/viking-1.6-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="GPS data editor and analyzer"
+HOMEPAGE="http://viking.sourceforge.net/"
+IUSE="doc +exif libexif gps +magic mapnik nls sqlite"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ doc? ( mirror://sourceforge/${PN}/${PN}.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+COMMONDEPEND="
+ app-arch/bzip2
+ dev-libs/expat
+ dev-libs/glib:2
+ net-misc/curl
+ sys-libs/zlib
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ gps? ( >=sci-geosciences/gpsd-2.96 )
+ exif? ( libexif? ( media-libs/libexif ) !libexif? ( media-libs/gexiv2 ) )
+ magic? ( sys-apps/file )
+ mapnik? ( sci-geosciences/mapnik )
+ sqlite? ( dev-db/sqlite:3 )
+"
+RDEPEND="${COMMONDEPEND}
+ sci-geosciences/gpsbabel
+"
+DEPEND="${COMMONDEPEND}
+ app-text/gnome-doc-utils
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ app-text/rarian
+ dev-libs/libxslt
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_configure() {
+ econf \
+ --disable-deprecations \
+ --with-libcurl \
+ --with-expat \
+ --enable-google \
+ --enable-terraserver \
+ --enable-expedia \
+ --enable-openstreetmap \
+ --enable-bluemarble \
+ --enable-geonames \
+ --enable-geocaches \
+ --disable-dem24k \
+ $(use_enable exif geotag) \
+ $(use_with libexif ) \
+ $(use_enable gps realtime-gps-tracking) \
+ $(use_enable magic) \
+ $(use_enable mapnik) \
+ $(use_enable nls) \
+ $(use_enable sqlite mbtiles )
+}
+
+src_install() {
+ default
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${PN}.pdf
+ fi
+}