summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/congen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/congen')
-rw-r--r--sci-geosciences/congen/Manifest2
-rw-r--r--sci-geosciences/congen/congen-1.6.1_p2.ebuild34
-rw-r--r--sci-geosciences/congen/congen-1.6.2.ebuild34
-rw-r--r--sci-geosciences/congen/metadata.xml9
4 files changed, 79 insertions, 0 deletions
diff --git a/sci-geosciences/congen/Manifest b/sci-geosciences/congen/Manifest
new file mode 100644
index 000000000000..03b5e5f24caf
--- /dev/null
+++ b/sci-geosciences/congen/Manifest
@@ -0,0 +1,2 @@
+DIST congen-1.6.1-r2.tar.bz2 287890 SHA256 2cdd41fc42e61603f25f34ded65f7823d9a0dda6454b791aa73d13ccd98f4058 SHA512 367f199e195e238cf5fc7349c2c0d912a4f9d2f2023b3106eb933e3799dc4624f0fd0c6fb27125c504ca22d3a723228a1d3e647e254cb1465fc6af48a2372dd6 WHIRLPOOL 48f31c041a1bc6d0088e229bcd32962507dda5e42452d8a60cb2572f0a9d7b7cf3e24c962cb6c70e85a1f0cf50c89df7f3e1baea24ec23d82b6d8484efd94403
+DIST congen-1.6.2.tar.bz2 293130 SHA256 8a8a458a2e797feb78183aa84656aad8064b8a40f0c0bb7a4d813d7d25e1f83c SHA512 21cabdf0fba8cfa8e72068db44e6db0288ce932f81f526f04421272550244de9c617dc12d2c162186cbb9f70d9a44aca48b6f132317fc2fa3c47860d2f58bad6 WHIRLPOOL d51588d177b32ad145c4594a8e8cf65814207f476708a6f5b26fefc77e994b19a9c44a3b18aa545bd735d130d096232df2488e38eb08f99b67846a66a77320db
diff --git a/sci-geosciences/congen/congen-1.6.1_p2.ebuild b/sci-geosciences/congen/congen-1.6.1_p2.ebuild
new file mode 100644
index 000000000000..b6a2efcb9cf3
--- /dev/null
+++ b/sci-geosciences/congen/congen-1.6.1_p2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P=${P/_p/-r}
+DESCRIPTION="A package for generating the speeds, equilibrium arguments, and node factors of tidal constituents"
+HOMEPAGE="http://www.flaterco.com/xtide/files.html"
+SRC_URI="ftp://ftp.flaterco.com/xtide/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sci-geosciences/libtcd-2.2.3"
+RDEPEND="${DEPEND}"
+
+MAKEOPTS+=" -j1"
+
+S=${WORKDIR}/${P%_p*}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}
diff --git a/sci-geosciences/congen/congen-1.6.2.ebuild b/sci-geosciences/congen/congen-1.6.2.ebuild
new file mode 100644
index 000000000000..9596a0aeec2a
--- /dev/null
+++ b/sci-geosciences/congen/congen-1.6.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P=${P/_p/-r}
+DESCRIPTION="A package for generating the speeds, equilibrium arguments, and node factors of tidal constituents"
+HOMEPAGE="http://www.flaterco.com/xtide/files.html"
+SRC_URI="ftp://ftp.flaterco.com/xtide/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+DEPEND=">=sci-geosciences/libtcd-2.2.3"
+RDEPEND="${DEPEND}"
+
+MAKEOPTS+=" -j1"
+
+S=${WORKDIR}/${P%_p*}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}
diff --git a/sci-geosciences/congen/metadata.xml b/sci-geosciences/congen/metadata.xml
new file mode 100644
index 000000000000..0744b87d36ba
--- /dev/null
+++ b/sci-geosciences/congen/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+</maintainer>
+</pkgmetadata>
+