summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-12-01 17:30:03 +0100
committerPacho Ramos <pacho@gentoo.org>2024-12-02 13:59:32 +0100
commita7e92f9a9b414a867e63fb9cce9b890fd53c0564 (patch)
tree5b592c31de513c7370ab201e1a08759e8ab77efe /sci-electronics
parentgnome-extra/gnome-shell-extension-pop-shell: fix pkgcheck warnings (diff)
downloadgentoo-a7e92f9a9b414a867e63fb9cce9b890fd53c0564.tar.gz
gentoo-a7e92f9a9b414a867e63fb9cce9b890fd53c0564.tar.bz2
gentoo-a7e92f9a9b414a867e63fb9cce9b890fd53c0564.zip
sci-electronics/gspiceui: drop 1.2.87
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gspiceui/Manifest1
-rw-r--r--sci-electronics/gspiceui/files/gspiceui-1.2.87-respect-users-flags.patch56
-rw-r--r--sci-electronics/gspiceui/gspiceui-1.2.87.ebuild82
3 files changed, 0 insertions, 139 deletions
diff --git a/sci-electronics/gspiceui/Manifest b/sci-electronics/gspiceui/Manifest
index b15a5fcc43e7..467846e1cbfe 100644
--- a/sci-electronics/gspiceui/Manifest
+++ b/sci-electronics/gspiceui/Manifest
@@ -1,2 +1 @@
DIST gspiceui-1.3.30_pre20240321.zip 80103549 BLAKE2B 5cdbd2338dd057d73a01572e75a7af145bca99f3e9339d259ae3615076e26a5c1614eecdd1e32cd669ecdd2a5cc1e3934dc3d3f1b36980c7a2eed7c6c15e1bb6 SHA512 736f7eafbaa26c3d9b3fa0df1ae5071adf21c0716519a99a0b9d199aa10a0dd402273de51d2e16b07be4c145ab2d34e133c515a8cfbb44068aa46cdc36a20658
-DIST gspiceui-v1.2.87.tar.gz 1089733 BLAKE2B c1801bfebd5d42fe9c1ab26e6fd0cb06b56cac53bbad272522896325e5fd979e6fcc63d6f99262b152180f249b5b2d4aa119aa83254a2fc07256574c9ebaef10 SHA512 081d04c39f4fb96139f12fa063dfb888e036948a00a6b55de3b04a49b2b4af01b45fd9b7f903855d798a71957452550dfa8c8505c167c239e27ada29cb6fa747
diff --git a/sci-electronics/gspiceui/files/gspiceui-1.2.87-respect-users-flags.patch b/sci-electronics/gspiceui/files/gspiceui-1.2.87-respect-users-flags.patch
deleted file mode 100644
index c39b6a329aba..000000000000
--- a/sci-electronics/gspiceui/files/gspiceui-1.2.87-respect-users-flags.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-diff --git a/src/Makefile b/src/Makefile
-index 50736fd..8dbfcfa 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -39,8 +39,8 @@ DESTDIR = /usr/local/bin
- #***************************************************************************************************
-
- # Which compiler and linker (eg. g++ or clang++)
--CXX = g++
--LD = g++
-+CXX ?= g++
-+LD ?= g++
- ifneq ($(GSPICEUI_MSWIN),0)
- LD += -static-libstdc++ -static-libgcc
- WINDRES = windres
-@@ -91,13 +91,7 @@ BINDIR = $(ROOT)/bin
- # -Os Optimize for size
- # -Og Optimize debugging experience but don't break debugging
- # -std=[C++NO] The C++ standard to use where C++NO is eg. c++98, c++03, c++11, c++14, c++17, etc.
--ifeq ($(GSPICEUI_DEBUG),0)
-- # Options for release (not using -Wall since it's GCC specific)
-- CXXFLAGS := -O3 -std=c++17 -pipe $(shell $(WXCFG) --cxxflags)
--else
-- # Options for development
-- CXXFLAGS := -g -Og -std=c++17 -Wall -Wextra -Wpedantic -pipe $(shell $(WXCFG) --cxxflags)
--endif
-+CXXFLAGS += $(shell $(WXCFG) --cxxflags)
-
- # I like to compile using the option "-Wall" etc., tests that break wxWidgets are turned off below
- ifeq ($(GSPICEUI_DEBUG),1)
-@@ -117,6 +111,7 @@ INCLUDES = -I.
-
- # Libraries
- LIBS := $(shell $(WXCFG) --libs core,base,html)
-+LIBS += -lm -lstdc++
- # (The pkg-config stuff was requested by a user, somehow pangox was missing) 2019-08-07 ???
- #ifeq ($(GSPICEUI_MSWIN),0)
- #LIBS := $(shell $(WXCFG) --libs core,base,html) # $(shell pkg-config --libs-only-l pangox)
-@@ -181,7 +176,7 @@ $(OBJDIR)/%.o : %.cpp
- # -o specify the output file name
-
- $(BINDIR)/$(PROG) : $(OBJS)
-- $(LD) -pipe -o $(BINDIR)/$(PROG) obj/*.o $(LIBS)
-+ $(CXX) -o $(BINDIR)/$(PROG) obj/*.o $(LDFLAGS) $(LIBS)
- ifeq ($(ROOT)/GSpiceUI.app,$(wildcard $(ROOT)/GSpiceUI.app))
- cp $(BINDIR)/$(PROG) $(ROOT)/GSpiceUI.app/Contents/MacOS/gspiceui
- endif
-@@ -223,7 +218,7 @@ tests : test_Component test_NetList test_CnvtType test_CmdNgSpiceOPT test_CmdNgS
-
- # Compiler options
-
--test_% : CXXFLAGS = -Wall -g -pipe $(shell $(WXCFG) --cxxflags)
-+test_% : CXXFLAGS += $(shell $(WXCFG) --cxxflags)
- ifeq ($(GSPICEUI_WXLIB),2.8) # This suppresses spurious warnings from gcc with wxWidgets v2.8.12
- test_% : CXXFLAGS += -Wno-unused-local-typedefs
- endif
diff --git a/sci-electronics/gspiceui/gspiceui-1.2.87.ebuild b/sci-electronics/gspiceui/gspiceui-1.2.87.ebuild
deleted file mode 100644
index 457548d8a92c..000000000000
--- a/sci-electronics/gspiceui/gspiceui-1.2.87.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-WX_GTK_VER="3.0-gtk3"
-inherit desktop optfeature wxwidgets xdg
-
-MY_P="${PN}-v${PV}"
-
-DESCRIPTION="GUI frontend for Ngspice and Gnucap"
-HOMEPAGE="https://sourceforge.net/projects/gspiceui/"
-SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="examples"
-
-DEPEND="
- x11-libs/wxGTK:${WX_GTK_VER}[X]
- sci-electronics/electronics-menu
-"
-RDEPEND="
- ${DEPEND}
- || (
- sci-electronics/ngspice
- sci-electronics/gnucap
- )
-"
-
-PATCHES=(
- # Use Gentoo LDFLAGS and CXXFLAGS
- "${FILESDIR}"/${P}-respect-users-flags.patch
-)
-
-src_prepare() {
- default
-
- # Adjusting the doc path at src/main/FrmHtmlVwr.cpp
- sed -i -e \
- "s:/share/gspiceui/html/User-Manual.html:/share/doc/${PF}/html/User-Manual.html:g" \
- src/main/FrmHtmlVwr.cpp || die
-}
-
-src_configure() {
- setup-wxwidgets
- default
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- dobin bin/gspiceui
-
- einstalldocs
- dodoc html/*.html html/*.jpg html/*.png
- dodoc ChangeLog ReadMe ToDo release-notes-v${PV}.txt
- doman gspiceui.1
-
- # installing examples and according model and symbol files
- use examples && dodoc -r lib sch
-
- newicon -s 32 src/icons/gspiceui-32x32.xpm gspiceui.xpm
- newicon -s 48 src/icons/gspiceui-48x48.xpm gspiceui.xpm
- make_desktop_entry gspiceui "GNU Spice GUI" gspiceui "Electronics"
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- if use examples ; then
- elog "If you want to use the examples, copy and extract from"
- elog "${EROOT}/usr/share/doc/${PF} the sch and lib directory"
- elog "side by side to your home directory to be able"
- elog "to generate the netlists as normal user."
- fi
- optfeature "schematics editing" sci-electronics/geda
- optfeature "waveform display" sci-electronics/gwave
-}