summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-04-21 12:19:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2022-04-21 12:19:45 +0200
commit333f5e1520569d2ff485bd02229056afb93c8caf (patch)
tree08d642b496842e025976338d598019f67e4e7649 /sci-electronics
parentapp-emulation/xen: enable CONFIG_CRASH_DEBUG on USE=debug (diff)
downloadgentoo-333f5e1520569d2ff485bd02229056afb93c8caf.tar.gz
gentoo-333f5e1520569d2ff485bd02229056afb93c8caf.tar.bz2
gentoo-333f5e1520569d2ff485bd02229056afb93c8caf.zip
sci-electronics/gazebo: bump to 11.10.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gazebo/Manifest1
-rw-r--r--sci-electronics/gazebo/files/qwt2.patch17
-rw-r--r--sci-electronics/gazebo/gazebo-11.10.2.ebuild85
3 files changed, 103 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/Manifest b/sci-electronics/gazebo/Manifest
index bfbca468808c..f643396f6d4b 100644
--- a/sci-electronics/gazebo/Manifest
+++ b/sci-electronics/gazebo/Manifest
@@ -1,2 +1,3 @@
DIST gazebo-11.10.1.tar.bz2 56483769 BLAKE2B 9d0aa1d8c21065fddc28d706632cc7bd1b8a3429c606ff51dcbe4657ec41fdfe60e2906dfd5efdcd8d6f1847694d8419957b386bc40aafac739e3277b7c577ab SHA512 ed78aebf0d53a7848dd0900f96082ae508f64bc8fe53277859b32880147643a1b1ff9c273cddfd9e34e8ec4ec53f93d13ba74f3edca16fdcf5e2a040509c5dc3
+DIST gazebo-11.10.2.tar.bz2 56496495 BLAKE2B 09bf370531214e9567d961445797cb50c9e5a81a405720c580d13e6b33029a63dd2cd9930dcbd239c1bf9091a9d5b092bfdef77b0b3524d281a10549e22e7c9a SHA512 8900c483f63cedb8543cfe718b336e3ec372fc0dc3d47ac9cd5378987fae634f16911d3c91fdf70add93b4a090e92f3558beec6c1277e1ba109652dcaf049ac2
DIST gazebo-11.9.1.tar.bz2 56472954 BLAKE2B c7a1c3c4a03112a90e8a0cb35dde32f5bb478dafb0d8c582d8cbad15ff1f43699782df3d69a75c47efec44d8a15ad96730f1ae9c1b5b0b1ff2099fbc6b8f2e4e SHA512 51af82305ef0758950e2752624cd98bd31abe55469a1cad6432b1edde1a8f896798a554c672f8694c080f7076d13fe1aa91b182227e26f04cb99e9e0f3907694
diff --git a/sci-electronics/gazebo/files/qwt2.patch b/sci-electronics/gazebo/files/qwt2.patch
new file mode 100644
index 000000000000..08e406055970
--- /dev/null
+++ b/sci-electronics/gazebo/files/qwt2.patch
@@ -0,0 +1,17 @@
+Index: gazebo-11.10.2/cmake/SearchForStuff.cmake
+===================================================================
+--- gazebo-11.10.2.orig/cmake/SearchForStuff.cmake
++++ gazebo-11.10.2/cmake/SearchForStuff.cmake
+@@ -847,10 +847,10 @@ find_path(QWT_INCLUDE_DIR NAMES qwt.h PA
+ /usr/local/lib/qwt.framework/Headers
+ ${QWT_WIN_INCLUDE_DIR}
+
+- PATH_SUFFIXES qwt qwt5
++ PATH_SUFFIXES qwt qwt5 qwt6
+ )
+
+-find_library(QWT_LIBRARY NAMES qwt-qt5 qwt PATHS
++find_library(QWT_LIBRARY NAMES qwt6-qt5 qwt-qt5 qwt PATHS
+ /usr/local/lib
+ /usr/local/lib/qwt.framework
+ ${QWT_WIN_LIBRARY_DIR}
diff --git a/sci-electronics/gazebo/gazebo-11.10.2.ebuild b/sci-electronics/gazebo/gazebo-11.10.2.ebuild
new file mode 100644
index 000000000000..c870b58b8472
--- /dev/null
+++ b/sci-electronics/gazebo/gazebo-11.10.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="A 3D multiple robot simulator with dynamics"
+HOMEPAGE="http://gazebosim.org/"
+SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# Subslot = major version = soname of libs
+SLOT="0/11"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/protobuf-2:=
+ virtual/opengl
+ media-libs/openal
+ net-misc/curl
+ dev-libs/tinyxml
+ >=dev-libs/tinyxml2-6:=
+ dev-libs/libtar
+ dev-cpp/tbb:=
+ >=dev-games/ogre-1.7.4:=[freeimage]
+ <dev-games/ogre-1.10
+ >=media-libs/freeimage-3.15.4[png]
+ sci-libs/libccd
+ >=media-video/ffmpeg-2.6:0=
+ sci-libs/gts
+ >=sci-physics/bullet-2.82:=
+ >=dev-libs/sdformat-9.1:=
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ dev-qt/qtopengl:5
+ dev-libs/boost:=[threads(+)]
+ sci-libs/gdal:=
+ virtual/libusb:1
+ dev-libs/libspnav
+ media-libs/freeimage
+ sci-libs/hdf5:=[cxx]
+ sys-apps/util-linux
+ media-gfx/graphviz
+ net-libs/ignition-msgs:5=
+ sci-libs/ignition-math:6=
+ net-libs/ignition-transport:8=
+ sci-libs/ignition-common:3=
+ sci-libs/ignition-fuel-tools:4=
+ <x11-libs/qwt-6.2.0:6=[qt5(+)]
+"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5
+ x11-apps/mesa-progs
+ test? ( dev-libs/libxslt )
+"
+BDEPEND="
+ || ( app-text/ronn-ng app-text/ronn )
+ app-arch/gzip
+ virtual/pkgconfig
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=(
+ "${FILESDIR}/qwt2.patch"
+ "${FILESDIR}/cmake.patch"
+ "${FILESDIR}/ffmpeg5.patch"
+ "${FILESDIR}/ffmpeg4.patch"
+)
+
+src_configure() {
+ # find OGRE properly
+ sed -e "s#lib/OGRE#$(get_libdir)/OGRE#" -i cmake/gazebo-config.cmake.in || die
+
+ local mycmakeargs=(
+ "-DUSE_UPSTREAM_CFLAGS=OFF"
+ "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
+ "-DUSE_HOST_CFLAGS=FALSE"
+ "-DBUILD_TESTING=$(usex test TRUE FALSE)"
+ "-DENABLE_SCREEN_TESTS=FALSE"
+ "-DUSE_EXTERNAL_TINYXML2=TRUE"
+ )
+ cmake_src_configure
+}