summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Kustov <ktrace@yandex.ru>2022-10-04 20:25:23 +0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-21 10:42:12 +0200
commit244fe3ccfa977e06616ca3faa48efd522692728c (patch)
tree3806c96c1d1addf1b7b2c570e72a369bae25c4cd /sci-electronics
parentsys-devel/lld: Stabilize 14.0.6-r1 ppc64, #877807 (diff)
downloadgentoo-244fe3ccfa977e06616ca3faa48efd522692728c.tar.gz
gentoo-244fe3ccfa977e06616ca3faa48efd522692728c.tar.bz2
gentoo-244fe3ccfa977e06616ca3faa48efd522692728c.zip
sci-electronics/librepcb: bump version to 0.1.7
- bump version - disable broken test Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Victor Kustov <ktrace@yandex.ru> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/librepcb/Manifest1
-rw-r--r--sci-electronics/librepcb/librepcb-0.1.7.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sci-electronics/librepcb/Manifest b/sci-electronics/librepcb/Manifest
index 3089c1f2947b..0f29f7f766af 100644
--- a/sci-electronics/librepcb/Manifest
+++ b/sci-electronics/librepcb/Manifest
@@ -1,2 +1,3 @@
DIST librepcb-0.1.5-source.zip 13111207 BLAKE2B 3a8c5f8b310971e1a6bd5b1fa8eb8059cd1c571e9ab369bf80c946ccbd320c258d5e8c65bea3b5a5bc4d85a38cac8205d5bbfbaad6aebf0a031315b73e9b99f4 SHA512 ed8c8fc154a03082bcbfe414bdb934870d09cf137811036a3ce59d70e1ad0b582fea64c31037c84e76a939bf1d087caabb9aa349578b525bce882e853a969653
DIST librepcb-0.1.6-source.zip 12671974 BLAKE2B bed8d6134159ec663dd88f9933ef0dad6d3bca70776537bf2e16397f0e4fd968a41661d95a118008fcf9d7d6d2432ebac81d78153b3c3ce8d69c64fb59aaf70e SHA512 a51ac2830d65bbd10be8904ecdcc6a7781d80c95e1423ed5bd04fcd009a0b7135ff3a49a87afe9e99006ae1f6ae44f2341021e5733675f2f20b05525860da5d7
+DIST librepcb-0.1.7-source.zip 13112342 BLAKE2B 53b6dad94febee84b60df1d848936f44093698c9965d4b24815395ff564a5634ab84f38574e7a1b6891f2cdd99b5162eb3747bbfdde2dfc2d680cff76a4e1cc1 SHA512 285ad661b9c528b1aa05c9a0482034af26e9344eb08a119ffabbadf518957a9784ccb9582bcfabcf5bf8982c33b6286b39722c0d59072df983925b3949b3e6c5
diff --git a/sci-electronics/librepcb/librepcb-0.1.7.ebuild b/sci-electronics/librepcb/librepcb-0.1.7.ebuild
new file mode 100644
index 000000000000..c2752d3b0f23
--- /dev/null
+++ b/sci-electronics/librepcb/librepcb-0.1.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2009-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake virtualx xdg
+
+DESCRIPTION="Free EDA software to develop printed circuit boards"
+HOMEPAGE="https://librepcb.org/"
+SRC_URI="https://download.librepcb.org/releases/${PV}/${P}-source.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ app-arch/unzip
+ dev-qt/linguist-tools:5"
+
+RDEPEND="
+ dev-cpp/muParser:=
+ dev-libs/quazip:=[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5"
+
+src_configure() {
+ local mycmakeargs+=(
+ -DUNBUNDLE_QUAZIP=ON
+ -DUNBUNDLE_MUPARSER=ON )
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/tests/unittests || die
+ # https://github.com/LibrePCB/LibrePCB/issues/516
+ virtx ./librepcb-unittests --gtest_filter=-SystemInfoTest.testGetUsername:CategoryTreeModelTest.testSort:BoardPlaneFragmentsBuilderTest.testFragments:BoardGerberExportTest.test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ ewarn
+ ewarn "LibrePCB builds might not be exactly reproducible with e.g. -march={native,haswell,...}."
+ ewarn "This can cause minor issues, see for example:"
+ ewarn "https://github.com/LibrePCB/LibrePCB/issues/516"
+ ewarn "For a completely reproducible build use: -march=x86-64."
+ ewarn
+}