summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2023-03-19 19:59:47 -0700
committerMatthew Smith <matthew@gentoo.org>2023-04-19 18:47:17 +0100
commit146f0a4b227e861dc3d185e825636b7bf2b5a06c (patch)
tree9e26f5e1ea5d9c0fcf31f5039ef45d917083d9cd /sci-electronics
parentsci-electronics/kicad: add 6.0.11 (diff)
downloadgentoo-146f0a4b227e861dc3d185e825636b7bf2b5a06c.tar.gz
gentoo-146f0a4b227e861dc3d185e825636b7bf2b5a06c.tar.bz2
gentoo-146f0a4b227e861dc3d185e825636b7bf2b5a06c.zip
sci-electronics/kicad-footprints: add 6.0.11
Bug: https://bugs.gentoo.org/899694 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad-footprints/Manifest1
-rw-r--r--sci-electronics/kicad-footprints/kicad-footprints-6.0.11.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-electronics/kicad-footprints/Manifest b/sci-electronics/kicad-footprints/Manifest
index 93fe6567d4d1..e866b345de4f 100644
--- a/sci-electronics/kicad-footprints/Manifest
+++ b/sci-electronics/kicad-footprints/Manifest
@@ -1,2 +1,3 @@
+DIST kicad-footprints-6.0.11.tar.bz2 23763091 BLAKE2B 8a4478a4dbdedef9d3f1f658b09065746e48d4e6f5ecfc89aacb0d53a0bb33a71b16ba6742062f6629b14e0b788485fb876076b82c576c8a72ef7bcc19fc74be SHA512 f30a7443bab7edb7943759d6b938be05b0fbc23d2c7c95f4b9e983c31295062dc1885cea076b5e06de2d1aa766b732471f34ae78c5f682cff1c024937acf8363
DIST kicad-footprints-6.0.9.tar.gz 31723499 BLAKE2B 33856d28a52f8f516c96c38c68aabe3d57c3f7eade5cb654cd0dca15f36263b9860f252468edf0b94f228c2497ef7e862cebfd023e2a166ce1696a89c1cff1e1 SHA512 43436a61fb1be66dc6cd6079e49e7af0f7d374f074874fd008eb45c2b3faee596e102173a274064a536f11c4525f223c9e8c2a33969811414811a226e69affaa
DIST kicad-footprints-7.0.0.tar.bz2 23928107 BLAKE2B 4f4a03b47f208ab431a41e6c20348e7d227a1dc6c24657308ff76cd800923993c2f937dbc737f5bdaa17703b6d1e435eac7b344a8f6462c500917ecffd4195a3 SHA512 fd6d7436838499a8ee1ed36ec23f1c7f85519e7f9641cb0a85556203dd51e7855e549d0cb1afe91c4a4885b62f87d4c765407d366728e6a6fbd64e75ac0ceb89
diff --git a/sci-electronics/kicad-footprints/kicad-footprints-6.0.11.ebuild b/sci-electronics/kicad-footprints/kicad-footprints-6.0.11.ebuild
new file mode 100644
index 000000000000..90a31fa8cb1f
--- /dev/null
+++ b/sci-electronics/kicad-footprints/kicad-footprints-6.0.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Electronic Schematic and PCB design tools footprint libraries"
+HOMEPAGE="https://gitlab.com/kicad/libraries/kicad-footprints"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/kicad/libraries/kicad-footprints.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://gitlab.com/kicad/libraries/${PN}/-/archive/${MY_PV}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ fi
+
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sci-electronics/kicad-6.0.0"
+
+if [[ ${PV} == 9999 ]] ; then
+# x11-misc-util/macros only required on live ebuilds
+ BDEPEND+=" >=x11-misc/util-macros-1.18"
+fi