summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/gresistor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/gresistor')
-rw-r--r--sci-electronics/gresistor/Manifest1
-rw-r--r--sci-electronics/gresistor/gresistor-0.0.1-r1.ebuild43
-rw-r--r--sci-electronics/gresistor/gresistor-0.0.1-r2.ebuild41
-rw-r--r--sci-electronics/gresistor/gresistor-0.0.1.ebuild38
-rw-r--r--sci-electronics/gresistor/metadata.xml11
5 files changed, 134 insertions, 0 deletions
diff --git a/sci-electronics/gresistor/Manifest b/sci-electronics/gresistor/Manifest
new file mode 100644
index 000000000000..f3b19b77f319
--- /dev/null
+++ b/sci-electronics/gresistor/Manifest
@@ -0,0 +1 @@
+DIST gresistor-0.0.1.tar.gz 25038 SHA256 c343a0cb05422d216eca7941ac11987165630f21516a430e679ac41459c3c4c2 SHA512 9d0165894e86ca4cdd63585a7e370045abdadef5089a4fbf7412ac31062ce4e4fdec934d3302f17a76ed1dc449bd5521682bc57d817a3fea88ac8afde8113ca2 WHIRLPOOL 8b4bca5298ff86aa0c938b0b0fd29963f481ffe10201a29e280020f0a7eacf27b2e3fdd03c813c620b82d4095199f17e04feb44c94cc8b14379a9be72742a21e
diff --git a/sci-electronics/gresistor/gresistor-0.0.1-r1.ebuild b/sci-electronics/gresistor/gresistor-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..ee0557609f64
--- /dev/null
+++ b/sci-electronics/gresistor/gresistor-0.0.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PYTHON_DEPEND="2:2.5"
+
+inherit distutils eutils
+
+DESCRIPTION="Translate a resistor color codes into a readable value"
+HOMEPAGE="http://www.roroid.ro/index.php?option=com_content&view=article&id=1:gresistor&catid=1:software-projects&Itemid=2"
+SRC_URI="http://www.roroid.ro/progs/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pygtk:2
+ x11-libs/gtk+:2
+ gnome-base/libglade:2.0"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ "README"
+)
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # fix typoes. Bug #416467
+ sed -i "s:Sylver:Silver:" ${PN} ${PN}.glade || die
+}
+
+src_install() {
+ distutils_src_install
+ newicon pixmaps/icon.png ${PN}.png
+ domenu ${PN}.desktop
+}
diff --git a/sci-electronics/gresistor/gresistor-0.0.1-r2.ebuild b/sci-electronics/gresistor/gresistor-0.0.1-r2.ebuild
new file mode 100644
index 000000000000..73f7bee7c992
--- /dev/null
+++ b/sci-electronics/gresistor/gresistor-0.0.1-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Translate a resistor color codes into a readable value"
+HOMEPAGE="http://www.roroid.ro/index.php?option=com_content&view=article&id=1:gresistor&catid=1:software-projects&Itemid=2"
+SRC_URI="http://www.roroid.ro/progs/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2
+ gnome-base/libglade:2.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+python_prepare_all() {
+ # fix typoes. Bug #416467
+ sed -i "s:Sylver:Silver:" ${PN} ${PN}.glade || die
+ distutils-r1_python_prepare_all
+}
+
+src_install() {
+ distutils-r1_src_install
+ newicon pixmaps/icon.png ${PN}.png
+ domenu ${PN}.desktop
+}
diff --git a/sci-electronics/gresistor/gresistor-0.0.1.ebuild b/sci-electronics/gresistor/gresistor-0.0.1.ebuild
new file mode 100644
index 000000000000..ffe5ec68b721
--- /dev/null
+++ b/sci-electronics/gresistor/gresistor-0.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+PYTHON_DEPEND="2:2.5"
+
+inherit distutils eutils
+
+DESCRIPTION="Translate a resistor color codes into a readable value"
+HOMEPAGE="http://www.roroid.ro/index.php?option=com_content&view=article&id=1:gresistor&catid=1:software-projects&Itemid=2"
+SRC_URI="http://www.roroid.ro/progs/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pygtk:2
+ x11-libs/gtk+:2
+ gnome-base/libglade:2.0"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ "README"
+)
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+ newicon pixmaps/icon.png ${PN}.png
+ domenu ${PN}.desktop
+}
diff --git a/sci-electronics/gresistor/metadata.xml b/sci-electronics/gresistor/metadata.xml
new file mode 100644
index 000000000000..5e3a61a90139
--- /dev/null
+++ b/sci-electronics/gresistor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+