summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-29 12:58:56 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-29 15:13:27 +0100
commitb9ba1ccd08b3739cda17b3188194fc9f9b015ac2 (patch)
treef6eb1cf6a1f042839e118e88408e3ec29ae5bc20 /sci-electronics/ghdl
parentdev-lang/nelua: rename live for proper order (diff)
downloadgentoo-b9ba1ccd08b3739cda17b3188194fc9f9b015ac2.tar.gz
gentoo-b9ba1ccd08b3739cda17b3188194fc9f9b015ac2.tar.bz2
gentoo-b9ba1ccd08b3739cda17b3188194fc9f9b015ac2.zip
sci-electronics/ghdl: drop old 3.0.0
Closes: https://bugs.gentoo.org/920538 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-electronics/ghdl')
-rw-r--r--sci-electronics/ghdl/Manifest1
-rw-r--r--sci-electronics/ghdl/files/ghdl-3.0.0-no-pyunit.patch16
-rw-r--r--sci-electronics/ghdl/ghdl-3.0.0.ebuild79
3 files changed, 0 insertions, 96 deletions
diff --git a/sci-electronics/ghdl/Manifest b/sci-electronics/ghdl/Manifest
index c435f58f6dca..854f17174cb9 100644
--- a/sci-electronics/ghdl/Manifest
+++ b/sci-electronics/ghdl/Manifest
@@ -1,2 +1 @@
-DIST ghdl-3.0.0.tar.gz 7160245 BLAKE2B 685d8976db48dd6d7074540ff24fae11e8d75f2b0e91de3095b356c9ed1e8dd762c486b7fb1df5a874a653181c6d4f4be4f8e3f5881d10db941c467a95590f45 SHA512 11b638d0ae757ce2e247ab438c15a8f5cd78c3a025ba6272aa05df548d2a7276c25dbbf83b846284ded8c9864eca3dcdb8342cb532faecd01e7cefaada524ab0
DIST ghdl-4.0.0_pre20231218.tar.gz 7761842 BLAKE2B d5b3ae4c28b245881681695cee74eca1d69092d8089cb1ec042f42d26e62aa420ace8f04899023d98259d845ea89700d77c453b892c176d4d1b367ac7a8237a6 SHA512 6b9ac7221bee5b8ec2cc7971fbad5aff615839aa3c3170fa39079c68e65da8b4a8d60f5c53d9fa88146c9f865b0d8a059fd03358e20b660b6543cf1b0c0b0c84
diff --git a/sci-electronics/ghdl/files/ghdl-3.0.0-no-pyunit.patch b/sci-electronics/ghdl/files/ghdl-3.0.0-no-pyunit.patch
deleted file mode 100644
index 7730d380494d..000000000000
--- a/sci-electronics/ghdl/files/ghdl-3.0.0-no-pyunit.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/testsuite/testsuite.sh
-+++ b/testsuite/testsuite.sh
-@@ -129,9 +129,10 @@ do_test() {
-
- pyunit)
- # The Python Unit testsuite: regression testsuite for Python bindings to libghdl
-- gstart "[GHDL - test] pyunit"
-- PYTHONPATH=$(pwd)/.. ${PYTHON:-python3} -m pytest -vsrA pyunit
-- gend
-+ # gstart "[GHDL - test] pyunit"
-+ # PYTHONPATH=$(pwd)/.. ${PYTHON:-python3} -m pytest -vsrA pyunit
-+ # gend
-+ echo "Python Unit testsuite is disabled!"
- ;;
-
- vests)
diff --git a/sci-electronics/ghdl/ghdl-3.0.0.ebuild b/sci-electronics/ghdl/ghdl-3.0.0.ebuild
deleted file mode 100644
index 6f2fa17fb6c8..000000000000
--- a/sci-electronics/ghdl/ghdl-3.0.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ADA_COMPAT=( gnat_2021 )
-LLVM_MAX_SLOT=15 # Check "configure" script for supported LLVM versions.
-
-inherit ada edo llvm toolchain-funcs
-
-DESCRIPTION="Open-source analyzer, compiler, and simulator for VHDL 2008/93/87"
-HOMEPAGE="https://ghdl.github.io/ghdl/
- https://github.com/ghdl/ghdl/"
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ghdl/${PN}.git"
-else
- SRC_URI="https://github.com/ghdl/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
- KEYWORDS="amd64 ~x86"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="llvm"
-REQUIRED_USE="${ADA_REQUIRED_USE}"
-
-RDEPEND="
- ${ADA_DEPS}
- llvm? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-util/patchelf
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-3.0.0-no-pyunit.patch )
-
-pkg_setup() {
- ada_pkg_setup
-
- use llvm && llvm_pkg_setup
-}
-
-src_prepare() {
- default
-
- sed -i "s|ar rc|$(tc-getAR) rc|g" Makefile.in || die
-}
-
-src_configure() {
- tc-export CC CXX
-
- local -a myconf=(
- --disable-werror
-
- --libdir=$(get_libdir)
- --prefix=/usr
-
- --enable-libghdl
- --enable-synth
- )
-
- if use llvm ; then
- myconf+=( --with-llvm-config=llvm-config )
- fi
-
- # Not a autotools script!
- edo sh ./configure "${myconf[@]}"
-}
-
-src_compile() {
- default
-
- patchelf --set-soname libghw.so lib/libghw.so || die
-}