summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-15 15:34:41 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-15 15:37:09 +0200
commit50b5f32ee3c6a71ed37d977e9a1169e1d3ef47e4 (patch)
treeeb22550ae147c2b66dac11b909f5b08cfa993577 /sci-chemistry
parentnet-libs/pjproject: update EAPI 7 -> 8 on 2.12.1 (diff)
downloadgentoo-50b5f32ee3c6a71ed37d977e9a1169e1d3ef47e4.tar.gz
gentoo-50b5f32ee3c6a71ed37d977e9a1169e1d3ef47e4.tar.bz2
gentoo-50b5f32ee3c6a71ed37d977e9a1169e1d3ef47e4.zip
sci-chemistry/molequeue: enable py3.10, py3.11 and disable py3.7
Fix build with USE="doc zeromq", if zeromq is enabled the docs are built into the ..._pythonX_Y BUILD_DIR instead of the cmake BUILD_DIR. Therefore we have to define HTML_DOCS within python_foreach_impl Closes: https://bugs.gentoo.org/846227 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild b/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild
index 5c4f667b458d..8901b0f81ce5 100644
--- a/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild
+++ b/sci-chemistry/molequeue/molequeue-0.9.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit cmake python-r1 virtualx
@@ -66,9 +66,14 @@ src_configure() {
src_compile() {
if use zeromq; then
- python_foreach_impl run_in_build_dir cmake_src_compile all $(usex doc documentation "")
+ my_src_compile() {
+ run_in_build_dir cmake_src_compile all $(usex doc documentation "")
+ use doc && export HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ }
+ python_foreach_impl my_src_compile
else
cmake_src_compile all $(usex doc documentation "")
+ use doc && export HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
}
@@ -81,7 +86,6 @@ src_test() {
}
src_install() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
if use zeromq; then
python_foreach_impl run_in_build_dir cmake_src_install
python_foreach_impl run_in_build_dir python_optimize